Skip to main content

BOOTMGR missing after restore

Beginner
Posts: 1
Comments: 7

Hello everybody.

I am new to this forum and I would like to have some help to solve my problem.

I have a desktop PC with WINDOWS7 ultimate 64 

ACRONIS TI 2011 build 6597 

Drive C: SSD

Please note the language I am using for Windows is French and I try to convert the messages (French) to English

After having restored the system (due to problems with WINDOWS) i got the message "BOOTMGR missing".

I have tried with the repair disk WINDOWS7 without succes.

I have also tried the procedure microsoft KB927392 and also the command Bootrec.exe

BOOTREC /FIXMBR      system respons:  operation succeeded

BOOTREC /FIXBOOT    system respons: the volume does not contain known files, check if all necessary system drivers are loaded and volume is not damaged.

BOOTREC /REBUILDBCD   system respons: the Windows installations have been analysed, number of Wiondows installations identified : 0

BOOTREC /SCANOS    system respons: number of identified Windows installations: 0

Because I suspect some damage in the BCD file I tried to identify the files ,and I found the following directory structure on the c:\ volume

The BOOT directory is not in the root but in c:\WINDOWS\BOOT

BCD is in c:\WINDOWS\BOOT\DVD\EFI and is 262144 bytes

BOOTMGR is in c:\WINDOWS\BOOT\PCAT and is 383562 bytes

I am able to start WINDOWS using the CD ACRONIS to boot

Thank you for giving some me some help

Forum Hero
Posts: 82
Comments: 9174

Top

With Windows 7, there is often a hidden partition called "system reserved" that contains the boot files.
When you backup, you need to make sure you have this partition included in the backup, in a disk and partition backup (not file backup). In fact you'd better make sure ALL partitions of your system disk are included in the backup
When you restore, you should restore the entire disk on the SSD. If you restore partition by partition, make sure that system reserved is marked active.

Some Windows7 system do not contain the system reserved partition. In particular, those that have been upgraded from a previous version of Windows.

So at this point;
- verify there is a system reserved, and that it is market active, using the windows DVD, a command prompt, and Diskpart.
- if you don't have a system reserved, make sure the C:\ partition is marked active.

If this doesn't solve your problem, do a repair install of Win7. That is pretty quick.

Beginner
Posts: 1
Comments: 7

Top

Hello Pat,

Thank you for comment and your time

There is no hidden partition on the c:\ drive and this drive is marked as active ,but remember I am booting Windows using the ACRONIS CD
Repair with the Win7 installation disk does not solve the problem.
I have looked into Microsoft 927392, reconstructing the BCD , but the procedure described in this article does not work because the directory structure is not as indicated . for example the direct BOOT is not in the root of c:\ but in c:\windows. (see above in first message.)

Forum Hero
Posts: 82
Comments: 9174

Top

Wilfried,

SImplest thing to do is to repair install Win7. It won't take long and it will preserve your apps and app settings.

Beginner
Posts: 1
Comments: 7

Top

Pat,

Do you mean reinstalling Windows 7 with the original WIN7 disc. ?
I have already tried to to use the repair function (MBR), without solving the problem

Furthermore I realise having made a mistake .
To limit SSD wear and continious read/write operations I have moved the files "DOCUMENTS AND SETTINGS" to a second hard disk of 500G
When a saved the c:\ drive with ACRONIS , the files "DOC&SETTINGS" on drive D:\ where of course not saved., and when I did a restore of the C:\ drive , these files are not anymore linked to Windows7 , on the c:\drive.

Forum Hero
Posts: 82
Comments: 9174

Top

Yes, I mean reinstalling with the original disk. This is a repair install. I have done once now. It takes about 15mn, then the upgrades...

Wait... there is no "documents and settings" folder with Win 7, are you talking about the Users folder or the AppData folder?
The best way to do what you wanted to do is to right click on each folder under c:\users\YourUser\ and to choose a new location on D.

Don't get too crazy about avoiding SSD wear... Do not move other folders, or Windows might get confused. Aside from the user content folders, leave them where they are by default. This will limit damage to Windows if you D:\ drive gets changed, etc.

Beginner
Posts: 1
Comments: 7

Top

Pat,

I followed your avdvice , and you'r right it is not complicated and all programs and settings are recovered

I reinstalled /repair with the original disk , but when I started this operation the system advised to shut down and restart WINDOWS, and therefore I needed to boot again with the ACRONIS CD.(and then I put the WINDOWS disk again in the PC)
During the installation the computer needed to restart a few times , (on each restart I got to use the ACRONIS CD to boot the operarting system)
After having installed Windows ,and the upgrades (59) , I then modified the BIOS to boot on the C:\ and rebooted the PC

and on the sceen :

"Loading operating system..." and then again " BOOTMGR MISSING".
It looks like I have no luck and need to do something else.

Forum Hero
Posts: 82
Comments: 9174

Top

Wilfried,

Wow, it is definitely an issue that you need the Acronis CD to be able to boot.

Why did you have to restart the machine on the Acronis CD after the repair? That's unexpected... You should have been able to reinstall Windows while keeping the default boot disk to C:\

Beginner
Posts: 1
Comments: 7

Top

Hello Pat, When I booted with the Windows disk , and then went to repair/install , i got the message "you have booted with the windows disk and the repair/install can only be done within the Windows environment, you should shut down the system and start again". During the reinstallation the system need to be restarted a few times , but the only possibility to restart (boot) Windows is to boot on the ACRONIS disk (because the BIOS is modified to have the first boot on the CD and not the harddisk).

 But I think this is not the issue because after severall updates I now have the Windows reinstalled., but when I try to reboot from the c:\ drive, the message is still BOOTMGR missing. I have done a BCDEDIT command and have the following details (remember I have the French language for my Windows

c:\windows<BCDEDIT

Gestionaire de demarrage Windows

identificateur         {bootmgr}

device                    partition=D

description             Windows Boot Manager

Locale                      Fr-FR

Inherit                    {globalsettings}

default                    {current}

resumeobject            {7c82aa4b-ee58-11df-922d-926b07f0bf86}

displayorder            {memdiag

timeout                    30

Chargeur de demarrage Windows

identificateur           {current}

device                      partition =c:

path                         \windows\system\32\winload.exe

description                Windows 7

locale                         fr-FR

inherit                        {bootloadersettings}

recovery sequence      {7c82aa4f-cc58-11df-922d-926b07f0bf86}

recovery enabled          yes

os device                    \windows

resume object             {7c82aa4f-cc58-11df-922d-926b07f0bf86}

hx                                  opt in

numproc                       4

usefirmwarepcisettings no

I do not have enough technical knowledge to understand above stttings of the BCD , may be You have ||

I found on the web a small utility program called EASYBCD , may be this could help if the BCD file need to be modified/reconstructed.

tnks again for trying to help me in solving this problem.

Forum Star
Posts: 45
Comments: 4263

Top

osdevice should be set to the booting partition, not a folder. It should be set the same as the device entry. For example: bcdedit /set {current} osdevice partition=C:

It's possible that you grabbed \Windows from the systemroot var since you didn't list it.

However, I think the problem here is that the boot partition is missing. The {bootmgr} section is pointing to partition=D, not C:. This seems to indicate that the booting files were/are on another partition (probably the System Reserved partition). I'm not sure if the missing colon in the drive letter would cause a problem or not. It should be partition=D:. Normally, the System Reserved partition is not assigned a drive letter, in which case it would be partition=\Device\HarddiskVolume1 (or something similar).

You could try fixing this by running the following command from an Administrator Command Prompt: bcdedit /set {bootmgr} device partition=D:

The files in the C:\Windows\Boot\... folders are not the booting files used when the Windows boots.

Can you post a screenshot of what Disk Management shows for the drive?

Beginner
Posts: 1
Comments: 7

Top

Helo Pat,

I am back again , and I have attached a sreenshot of the disk management

Attachment Size
64908-95491.jpg 421.96 KB
Forum Star
Posts: 45
Comments: 4263

Top

It appears that the System volume is the first volume on the Dynamic Disk. Is there a reason that it's Dynamic?

What I would recommend is moving the booting files from D: to C: so that the Windows partition is the booting partition.

Can you check the D: partition for the \Boot folder and the BCD file?

You can do this in Explorer if you enable viewing of hidden and system files. You can also check from an Administrator Command Prompt.

Forum Hero
Posts: 82
Comments: 9174

Top

Your C: disk should be System, boot, Active.
Currently your D: disk is System.

As Mudcrab suggested, unhide hidden files AND system protected files. Verify the bootmgr file and the boot folder are under D:
If there are, boot on the WinDVD, launch a command prompt, and copy these files manually from D:\ to C:\
Delete them from D:\
Reboot and use the WinDVD to repair the startup. It might take a few of times as startup repair does one fix at a time. Always reboot on the Win DVD, do not swith to the Acronis CD.

Acronis doesn't support dynamic disks unless you have the Plus Pack.

Beginner
Posts: 1
Comments: 7

Top

I don't know why the d: drive is called dynamic (it is a 1 Tb hard disk with partition d,e,and f.

Checking with the administrator command it appears there is no boot folder and no BCD on drive D:\

Forum Star
Posts: 45
Comments: 4263

Top

Which drive is the booting drive in the BIOS? I assume it is the Windows drive (111.79GB).

I suspect that the repair attempts set the D: partition as the system partition for some reason, but it's not correct.

This is what I would try: Disconnect every drive except the Windows C: drive (the SSD?). Make sure it's set as the booting drive in the BIOS. Boot to the Windows 7 DVD and do a boot repair. You may need to run the repair three times, letting it restart inbetween.

The Windows boot repair can correct a system with no booting files (I've tested it before). It's possible that it's just getting confused because of the other partitions/drives.

Beginner
Posts: 1
Comments: 7

Top

YES, YES YES !!!!!!!!!!!!!!!!!!

The system is up and booting again on the c:\drive Thank you very much both of you , you helped me out of a nightmarry., it is fantastic

I disconnected all drives except the c:\ drive (SSD) Then I put the WINDOWS DVD,and selected repair, and the system responded that it found some damage on the start-up equence , it then repaired and rebooted again to do some more repair. I then remodified the BIOS to start on the hard disk , and Windows booted up .

I have one more small problem : the system could not find the desktop file : it says d:\Wilfried\desktop is making reference at an location which is not available

When I reconnected the D:\ drive the problem disappeared

Can you please confirm if i move the desktop and other directorys like "my documents" to the c:\ (with the windows explorer) i will have everything back again on the c:\ drive 

Thanks again for the time you spent to solve the problem

Forum Star
Posts: 45
Comments: 4263

Top

As far as I know, you should be able to just move them back. As long as the Location for the folders is set correctly I think it should be fine. Personally, I just leave all those as default and then use standard folders to organize my files.

You should be able to cut & paste with Explorer or you could right-click the folder, select Properties, and then use the Location tab.

Beginner
Posts: 0
Comments: 1

Top

Make sure you select the reserved partition as well as your main drive (System Reserve & Local Disk). That solved it for me.