Skip to main content

Delay doesn't work

Thread needs solution
Forum Member
Posts: 4
Comments: 21

It is possible to enter a delay in the advanced settings in planning a backup (see the attachment). However, the delay doesn't work and the backup starts immediately after starting windows.

I use Windows 8 and True Image 2013, build 6514

Attachment Size
knipsel.png 27.04 KB
0 Users found this helpful
Forum Star
Posts: 8
Comments: 1344

#1

Rob,
By chance did you add the delay by editing the task after it was created?

If so, I suggest creating a new task specifying the delay when the task is created and see if this resolves the issue.

Others might have additional suggestions.

Legend
Posts: 172
Comments: 11125

#2

If I am understanding your issue correctly,
If the backup is missed, you want the schedule backup to occur on next bootup with a 30 minute delay before the backup program is initiated.

If I am understanding correctly, the backup does successfully begin at bootup but the delay is not invoked--which is the problem. Is this correct?

Winodws 8 has had reported scheduler issues with some suggested workarounds. Whether this is your situation, I am unsure. You could add this workaround to your scheduler2 services--just in case. Making the change cannot hurt your system performance so there is no downside to making the change in services value.

An extract from this link by Acronis explained here:

http://forum.acronis.com/forum/41222#comment-131503

"To get rid of this error, as a temporary solution, you can do the following:

Go to Services (Start -> type services.msc -> Hit Enter), make right-click on Acronis Scheduler2 Service -> Properties -> open Recovery tab -> Set the VALUE for the First, Second and Subsequent failures to "Restart this service" for all three windows.
---------------------------------
Additionally,
Create a new task with all the correct settings and point to a new and empty storage folder. Editing a backup task has been known to cause issues with the backup program not performing as needed so avoid edits.

if the built-in startup delay is not working, I am not aware of any other settings to delay Acronis just at startup.

It is possible to delay the execution on the actual backup everytime it starts. Thus, a delay could occur prior to a bootup start of Acronis knowing that the delay command would also occur during a normal scheduled start of the backup--for this specific task. This delay could be induced via a batch/command file placed inside the "Disk Backup Options - Pre/Post PRE Commands option.

This is an example of what could be copied/ pasted into Notepad and saved as a command file.


%WINDIR%\SYSTEM32\TIMEOUT.EXE /T 60

Note: change the 60 seconds to whatever number of seconds needed for the delay such as 1800 if wanting a 30 minute countdown.
NOTEPAD--saved as
C:\Timed-delay.CMD

The Acronis PRE command would point to
C:\Timed-delay.CMD

Note: you may need to open Notepad using an elevated "Run as administrator" option in order to have proper save credentials.

For testing, double click on the c:\Timed-delay.cmd file using any number of seconds you wish to test. Editing this cmd file is not considered as editing the backup task.  The delay could be aborted via "Press any key" but tht may also stop your backup from running. You would have to test the use of aborting the delay via the "press any key" abort option. Or, you can also use the builit in test command of the Pre command.  Duriing this test, pressing the "Press any key" option aborts the countdown and a successfuyl indication shows the command will work and that the backup WILL CONTINUE EXECUTION when the countdown is aborted via the "Press any key" option.

This successful Acronis test would seem to  indicate that having the countdown be a part of backup task is not really a problem as an unwanted countdown could be aborted and normal task would begin immediately.  This appears to be a viable option--if it fits your needs.