Skip to main content

[DUPLICATE] Slow folder display issues possibly caused by Acronis True Image 2013?

Thread needs solution
Beginner
Posts: 2
Comments: 10

I upgraded to the free Acronis True Image 2013 upgrade yesterday from True Image Home 2012 which I purchased last week. ATIH 2012 was working fine, no problems, but I noticed that ATI 2013 had several new services which I didn't need such as the Synchronisation so I decided to disable the service.

Aside from triggering warnings from ATI 2013 that schedules couldn't be run, etc., I found that when I opened Explorer or Computer that the contents sometimes appeared straight away as they normally do but more often took ages or didn't appear at all as a green bar slowly crawled across the screen. I thought something was wrong with my PC and ran Chkdsk, sfc /scannow and anti-virus/anti-malware programs to try to identify what was causing this weird issue. No errors were reported, Windows loaded as quickly as it always did (it is installed on a Crucial M4 SSD) and games and apps load as normal from desktop shortcuts and the Programs menu. I just could not find what was causing this issue. I then re-enabled the Acronis Sync Agent Service and now the windows open and display the folders and icons as quickly as before. Unless it is just a complete coincidence, it seems to me that the Sync Agent app is somehow tied in to Explorer and disabling it causes problems with displaying window contents.

Question: Regardless of whether that is the case or not, why is it not possible to disable the Sync service anyway? I have no need of it but it seems I have to have it running with an annoying icon in the system tray that I can't get rid of. Surely it should be possible to customise ATI 2013 to your individual needs but I noticed that this version (and I believe 2012) no longer have an Options category.

Issue is discussed in this thread.

0 Users found this helpful
Legend
Posts: 172
Comments: 11125

Using either 2012 or 2013, I stop the service and change to disabled both the NONSTOP Service plus the SYNC-AGENT Service. Neither service is required.

I also find that I should NOT disable the "Acronis Scheduler2" service as it seems to affect the program performance.

Another feature that I stop is the "Scan for Backups" at each starting of the TrueImage program as illustrated in this link.

http://forum.acronis.com/forum/31895

The link below may help you to find some of the options that the user can adjust.
http://forum.acronis.com/forum/28705

Also, check the options in the upper right corner within the help area.

Regular Poster
Posts: 15
Comments: 123

This seems like the same issue I reported in

http://forum.acronis.com/forum/35152

I also disabled the Sync Agent, but never re-enabled it.

I submitted a trouble report, but have not heard back from Acronis yet.

Since I could not find a solution, I reverted from ATI 2013 to my system image before the install.

Forum Star
Posts: 46
Comments: 2759

You can safely disable the Sync service, but the issue you are experiencing is because you are signed into your Acronis account from within True Image 2013. That is why you see the Sync icon in your system tray. If you are not using the Online backup or Sync features and/or the Non-Stop Backup feature, you can disable one or both of the services. Be sure both are enabled before logging out of your Acronis account from within 2013, then click on your email address shown in the upper right corner of the main screen to logout, exit 2013, stop the services, and set them to Disabled. Restart your system, and test for correct operation of Windows Explorer and 2013. You should not log on to your Acronis account in 2013 if you have the Sync service turned off. 2013 expects it to be running to maintain the default Sync between your system and the Acronis Cloud. The default Sync will not show up on the Sync tab if you are not logged in to your Acronis account in 2013, instead you will have a login page under the Snyc. tab.

Beginner
Posts: 2
Comments: 10

@ arachnaut - Yes, having read your post that is the same behaviour I was experienced... the green bar slowly crawling across the top of the window and a message about 'Searching for files...'. I've been using my PC for an hour now with everything enabled in ATI 2013 and all is back to how it was.

@ James F - Thanks for the info.

Surely it should not be so complicated to disable a feature of ATI 2013? Why not just have a disable Sync and Non-Stop Backup option in the ATI 2013 software itself and have that disable the services and sign out if you're logged in with an appropriate message as to why you're being signed out. It would certainly add a bit of user-friendliness to the software IMO. Less knowledgable people might have wasted time reformatting their PCs over the issues I had with Explorer; in fact, at one point I wondered if my hard drives were dying!

Forum Star
Posts: 46
Comments: 2759

DH,
I agree with you 100%, but to get your message across to Acronis you would be better doing so here: https://www.acronis.com/my/feedback.html. This is the official feedback link. Be sure to let them know how you feel about the program and make your suggestions for improvement. Only by folks communicating to Acronis in this way will product improvments and changes be considered. Posting on the forums does not have the same impact, as the forums are only occasionally visited by Acronis staff.

Beginner
Posts: 2
Comments: 10

Well I followed your advice and logged out of ATI 2013 then disabled both the Sync Agent and the Non-stop Backup services. I then restarted my PC and checked the ATI 2013 had not logged in (it hadn't). I'm still seeing some unusual pauses and green bars that I didn't have prior to installing ATI 2013 though. It better than it was but it seems that ATI 2013 is still hooked into Explorer and causing delays in opening folders. For example, I opened my Downloads folder which only has about a dozen smallish files in it, a few PDFs, a couple of JPEG images and several third-party installers, yet it took 10 seconds or so to display the contents. Doesn't happen everytime but it shouldn't happen at all as prior to installing ATI 2013 or with the Sync Agent running/being logged in the folder contents would display instantly.

Seems that the Sync Agent does not like being disabled on my system and I get better folder peformance if I leave it enabled. I guess I'll have to report this issue to Acronis and hope that they can fix it because it is annoying. I've been using ATI since 2009 and I've never had any problems or compatibility issues until this version.

Beginner
Posts: 2
Comments: 10

Also (I noticed this earlier as well), icons are taking a long time to refresh, e.g. the Open File window doesn't show any drive icons (they're just white squares), and if I right-click on a file and select Properties then the hour glass mouse icon appears. Basically, Windows is not working the way it should - it's like it is back to running from a hard drive not an SSD to be honest - so I'll have to re-enable the Sync Agent and see what happens. I've informed Acronis of this thread via the Feedback link you provided so hopefully they will be able to throw some light on it.

Forum Star
Posts: 46
Comments: 2759

You may want to re-enable the sync service and sign back into your Acronis account. The sync between your system and the Acronis Cloud should then be allowed to complete, indicated on the sync tab and by hovering over the system tray icon. Once the sync is complete, log out of your Acronis account and try the suggestions I mentioned again to see if your results are different. Also check your Windows Integration settings by clicking the gear icon in the top right hand side of the program. Try disabling all of the integration features for testing purposes. You could then enable them one by one for troubleshooting.

Beginner
Posts: 2
Comments: 10

I re-enabled Sync Agent and logged into ATI 2013 then rebooted my PC (since the windows were still acting up at that point). Post-boot the windows/Explorer are now back to behaving normally; icons appear straight away and right-clicking on the files and selecting Properties works instantly.

I'll do as you suggest but it seems the Sync Agent is a bit buggy, at least for me, and it really should not be causing this kind of behaviour IMO. I'm using Windows 7 SP1 64-bit.

Many thanks for your help. Appreciate it.

Forum Star
Posts: 46
Comments: 2759

Additionally, slow opening of folders in Windows is usually the result of shell extensions that are installed conflicting with each other or are poorly written by the software vendor. Because there are so many different applications that add these extensions, tracking down the problem is sometimes a nightmare. One some system the Acronis shell extesions work fine in combination with whatever else is there, others have problems such as yours. A great utility to manipulate these extensions with is ShellExViewer by Nirsoft. It can really give you a good glimpse of what your system has installed as shell extensions. http://www.nirsoft.net/utils/shexview.html

Regular Poster
Posts: 15
Comments: 123

I think Doctor Hades comments reflect my own - new features, however welcome by some, are not used or needed by others. They should be allowed to be disabled in the installation menu.

My opinion is that Acronis True Image is an imaging, backup software. It usually does that very well and very efficiently, that's why it is so popular. Anything else is just icing and should be treated as options.

Of course, a complex software like Acronis, with software hooks into the file system, can be a bit difficult to debug in various systems - all the more reason to design these things in the beginning to be options.

Beginner
Posts: 2
Comments: 10

@ arachnaut - Agreed. I'm amazed that there is no option to actually disable Synchronization. Even when you're not logged in the service is still running unless you manually disable it under Services. You really shouldn't have to mess around doing that, it should be an option in the software itself.

Forum Member
Posts: 5
Comments: 77

Well - I also agree - I had the same problems - although never logging in and never having used the sync-thing or nonstop......
I had them deactivated a while after installing - a while, because the problems had shown before I could do so - I also had freezes + the ComSurrogate-notification coming up every 2-5 second - and after all workaraounds did not help me - I have restored the System and are now happy to habe everything running fine again ( W7Profx64SP1) and now I am waiting for a Build that works ok with my system.

Beginner
Posts: 2
Comments: 10

Well enabling Sync Agent (and logging in to ATI 2013) has fixed the Explorer issue I had but I would like to be able to disable that service permanently as it is free for only 30 days anyway and I have no need for it. I might have 12 GB of memory but I do not want unnecessary services running in case they cause conflicts with other software I might use in the future. I prefer to only run what I'm actually using.

Forum Hero
Posts: 613
Comments: 8747

If you log out of Sync first and then disable the service, Windows shouldn't be affected.

Beginner
Posts: 2
Comments: 10

@ Colin B - I tried that last night after making sure that Sync Agent wasn't actually syncing anything (it wasn't as the Sync folder is empty anyway). I logged out of ATI 2013 then stopped the Sync Agent service manually (I got an error that it couldn't be stopped so I tried again and it eventually did stop). I checked Task Manager to make sure the Sync Agent was not running but found I still had issues with Explorer being slow at displaying folders and icons. It wasn't as bad as before but it was still clearly affected even after a reboot when neither the Sync Agent was running nor was I logged into ATI 2013.

It seems that the only way to guarantee that Explorer is unaffected is to leave the Sync Agent running in which case folders and icons appear instantly. As I said earlier it could be a bug in tishell64.dll perhaps.

I assume tishell64.dll is also part of the ATI 2013 shell integration which I have enabled (all three options). I have not yet tried unchecking all of those to see if one of those is possibly causing the problem when Sync Agent is disabled.

Frequent Poster
Posts: 287
Comments: 535

Hi,

Yes the slow display is caused by stopping the SyncAgent even if you let the system start normally and then stop SyncAgent it will eventually cause the issue you are seeing. Another test for this is to go to the start button select a program, right click as if to "run as Administrator" and you will find that the start button and the task bar will now be hung and will not operate.

To resolve the issue so you can get the use of your system back without rebooting you can do the following:

1). do CTRL-ALT-DELETE and select start task manager or start task manager by right click on the task bar if it is still working
2). then show the processes tab
3). click the "show processes from all users" and supply the administrator password if required via UAC
4). from the file menu select "new task (run)"
5). when the popup appears select browse
6). browse to %windir%\system32\resmon.exe then select open
7). supply the administrator password if required via UAC
8). on the resmon window select the overview tab
9). look for explorer processes
10). right click and use "Analyze wait chain..." and look for an explorer process that is waiting on dllhost.exe
11). make a note of the process ID (PID)
12). look in the list of programs again for a dllhost process that has the same PID
13). select it, right click and kill the process

You should then get the use of your system back again until the next time - it seems after a time the issue will re-occur

It is always dllhost.exe that is waiting on something that causes the issue. I do not have the knowledge to see what it is waiting on but I do know the every time you start a program a new dllhost.exe process is created to make it happen. After the program starts the dllhost.exe process terminates, at least it should but when the syncagent is stopped something goes awry.

Also if you set SyncAgent to manual it will not start when the system boots but it will start each time you run the ATIH GUI.

You cannot stop the SyncAgent if the GUI is running - at least that is what seems to be the case

BTW all the above is on my W7-64Bit system - it may be different on others but hopefully this will give you some clues.

Regular Poster
Posts: 15
Comments: 123

If Acronis posts a fix for this, I will try a new install of ATI 2013, until then, I'm still happy with ATI 2011.

Forum Star
Posts: 88
Comments: 4769

Hello Everyone,

Thank you very much for your suggestions and ideas, we really appreciate them.

I am very sorry for locking this thread, but we have an older one that deals with the same issue. I would really appreciate if you could continue posting your comments there so that we can keep all the comments in one place.

Thank you.