Skip to main content

Error: Not enough memory

Thread needs solution
Forum Member
Posts: 12
Comments: 26

True Image Home 2011 (Build 6696) does not work: I tried to make an image backup of several partitions (tried target on internal and on external hard-disk). Both times it stopped at the begin with the error "not enough memory" - but I have 8 GB of memory!!

Windows 7 Ultimate 64bit 1.
Target internal hard-disk: 2 TB (1.5 TB free)
2. Target external USB 3.0 hard-disk: 1.5 TB
Estimated backup size: 500 GB

Is it possible that True Image cannot handle large target drives (1.5 - 2 TB)? I don't have any problems with these drives in Windows. My system is very fast (Phenom II X6 1090T, 8 GB memory, best hardware a user can buy ...). There are no errors in Windows, everything works fine.

So what can I do to get True Image to work?

http://img263.imageshack.us/img263/6238/notenmemory.gif

0 Users found this helpful
Forum Hero
Posts: 87
Comments: 9259

Peter,

This looks more like an installation issue and/or some hardware issue on you system.

Uninstall 2011, use the cleanup utility, reboot, reinstall 2011 and verify if the issue subsists.

If possible, try a disk that is not USB 3.0. Maybe there is a driver issue for ATI there.

If the issue subsits on a USB 2.0, run a memory test on boot and see if there are errors. If there are errors, move/unplug your memory cards to identify/eliminate the issues.

Run chkdsk /r on the disks. Verify if the issue subsists.

Forum Member
Posts: 12
Comments: 26

Hi Pat, thanks for answering.

I've reinstalled TIH many times (I am sick of reinstalling), this is not an installation issue.

As I've written in my post, I also used an internal SATA drive (most modern and expensive WD professional storage drive) with 2 TB as target.

It really seems that TIH has issues with large target drives. Also my system partition is on a SSD (240 GB). Maybe TIH cannot handle SSDs either?

Forum Hero
Posts: 87
Comments: 9259

Peter,

2TB disk... When you look at Windows disk management, is it a basic disk or a dynamic disk? Is it MBR or GUID disk?

ATI 2011 works fine with SSDs. This is what I have.

I would suspect a disk mismatch (ATI doesn't support dynamic disks, unless with the Plus Pack), a USB 3.0 driver issue for ATI or a memory hardware issue on your system.

Forum Member
Posts: 12
Comments: 26

Pat, the 2 TB disk is an INTERNAL SATA disk. Here is what I see in Acronis Disk Director 11:

http://img135.imageshack.us/img135/3778/ydisk.gif

Here is a report about the drive from HWInfo32:

WDC WD2002FYPS-02W3B0 -----------------------------------------------------

[General Information]
Drive Controller: Serial ATA 3Gb/s
Drive Model: WDC WD2002FYPS-02W3B0
Drive Revision: 04.01G01
Drive Serial Number: WD-WCAVY5520579
Drive Capacity: 1,907,729 MBytes (2000 GB)
Drive Capacity [MB]: 1907729
Media Rotation Rate: 5400 RPM
[Drive Geometry]
Number of Cylinders: 16383
Number of Heads: 16
Sectors Per Track: 63
Bytes Per Sector: Unknown
Bytes Per Track: Unknown
Number Of ECC Bytes: 50
Number of Sectors: 16514064
Total 32-bit LBA Sectors: 268435455
Total 48-bit LBA Sectors: 3907029168
Cache Buffer Size: N/A
Controller Type: Not Specified
[Transfer Modes]
Sectors Per Interrupt: Total: 16, Active: 0
Max. PIO Transfer Mode: 4
Multiword DMA Mode: Total: 2, Active: -
Singleword DMA Mode: Total: -, Active: -
Ultra-DMA Mode: Total: 6 (ATA-133), Active: 6 (ATA-133)
Max. Multiword DMA Transfer Rate: 16.7 MBytes/s
Max. PIO with IORDY Transfer Rate: 16.7 MBytes/s
Max. PIO w/o IORDY Transfer Rate: 16.7 MBytes/s
Transfer Width: 16-bit
Native Command Queuing: Supported, Max. Depth: 32
TRIM Command: Not Supported
[Device flags]
Fixed Drive: Present
Removable Drive: Not Present
Magnetic Storage: Present
LBA Mode: Supported
DMA Mode: Supported
IORDY: Supported
IORDY Disableable: Supported
[Features]
Write Cache: Present, Active
S.M.A.R.T. Feature: Present, Active
Security Feature: Present, Inactive
Removable Media Feature: Not Present, Disabled
Power Management: Present, Active
Advanced Power Management: Present, Active
Packet Interface: Not Present, Disabled
Look-Ahead Buffer: Present, Active
Host Protected Area: Present, Enabled
Power-Up In Standby: Supported, Inactive
Automatic Acoustic Management: Supported, Active
48-bit LBA: Supported, Active
[Self-Monitoring, Analysis and Reporting Technology]
Raw Read Error Rate: 200/51, Worst: 200
Spin Up Time: 226/21, Worst: 225 (Data = 10691)
Start/Stop Count: 100/Always OK, Worst: 100 (Data = 101)
Reallocated Sector Count: 200/140, Worst: 200
Seek Error Rate: 200/Always OK, Worst: 200
Power-On Time Count: 100/Always OK, Worst: 100 (Data = 661)
Spin Retry Count: 100/Always OK, Worst: 100
Calibration Retry Count: 100/Always OK, Worst: 253
Power Cycle Count: 100/Always OK, Worst: 100 (Data = 80)
Power-Off Retract Count: 200/Always OK, Worst: 200 (Data = 3)
Load/Unload Cycle Count: 200/Always OK, Worst: 200 (Data = 97)
Temperature 120/Always OK, Worst: 118 (Data = 32.0 °C)
Reallocation Event Count: 200/Always OK, Worst: 200
Current Pending Sector Count: 200/Always OK, Worst: 200
Off-Line Uncorrectable Sector Count: 100/Always OK, Worst: 253
UltraDMA CRC Error Rate: 200/Always OK, Worst: 200
Write Error Rate: 100/Always OK, Worst: 253

---

Thank you for your help! BTW, what do the numbers in the error message mean? (See screen-shot from my first post).

However, if TIH fails on different disk types, wouldn't it be logical to assume that the culprit is TIH itself?

Forum Hero
Posts: 87
Comments: 9259

I don't know what the error codes mean specifically. They and what the message mentions might not be directly the core issue.

Your disk is fine: it is a basic MBR disk.

That Disk Directore sees it doesn't mean ATI can deal with it, necessarily.

Did you try on a non USB 3.0 port?

Forum Member
Posts: 12
Comments: 26

Pat, thank you for your help.

But, again, this is an internal SATA disk, not USB attached.

Forum Hero
Posts: 87
Comments: 9259

Right. I saw you tried the backup on the internal and on the external disk without difference.

Possible reason #1: Disk issues.
1-a How full are your disk? I have seen users reporting this error message when disks are becoming pretty full.
1-b Did you run a chkdsk /r?

Possible reason #2: SnapAPI issues. Since the failure happens at the beginning of the backup, I would suspect the snapshot is failing.
Did you upgrade ATi from a previous version or is it a clean installation? Sometimes, upgrading create some issues with the low level drivers...

Possible reason #3. Memory issues. A memory hardware issue is still possible. When you have the time, run a memtest88 for a night or so http://www.memtest86.com/download.html. At least this will remove one variable.

Not an exclusive list, but I am running out of ideas...

Forum Member
Posts: 12
Comments: 26

The 2 TB disk has 1.5 TB of free space, while the estimated backup size would be 500 GB.

No, I uninstalled everything, then installed the newest version.

Ah, BTW, I also have the TIH Plus package. Could this be relevant?

I have done an extensive memory test (over one night) after buying the memory. AFAIR there were no errors (in the opposite case I would have them returned).

Forum Hero
Posts: 87
Comments: 9259

Peter,

OK. This leaves us with some potential issues with ATI's drivers.

When you did your installation/reinstallation did you use the 2011 cleanup utility?

The cycle should be:
- uninstall 2011
- run the cleanup utility
- reboot
- reinstall 2011

For example, in the device manager, you should see only one Acronis device (if there are 2, this is not the reason of your issues, but a sign that you have installation remnant issues).

If you used the cleanup utility, contact Acronis to get the latest SnapAPI and install them separately.