Skip to main content

Error while parsing script file

Thread needs solution
Beginner
Posts: 1
Comments: 0

I have True Image Home 2012. Worked great until I made a simple setting change very recently. My email password had changed and I went to Settings > Notification and changed the password to my new one. After saving the settings, I get this messag:

Error while parsing script file.

I was able to recover by getting the problem script files from my backup.

Same thing happens again when I attempt to change my email password.

I did a file compare on the good script vs the bad script. The files are identical except for the one which contains the list of backup volumes. In that file the "execution_count" is formatted incorrectly after saving the settings.

incorrect: execution_count="1,033"

   correct: execution_count="1033"

Note the comma should not be in the execution count. This only becomes an issue when the "execution count" goes over 999 and it's only corrupted by saving the settings.

This happened to me because this backup has been in daily use for over 1000 days. That's 2.8 years of reliable backups!

0 Users found this helpful
Legend
Posts: 81
Comments: 17545

#1

Hello John,

It looks like you have identified the root cause of the script parse error message and therefore have a solution to this issue, i.e. copy the encoded new password from the incorrect script into the correct one, or alternatively create a whole new backup task with the correct credentials where the execution count will be a single digit.

Unfortunately there is no support available for ATIH 2012 unless you haven't upgraded to the last available build version that was released for it.

MS
Beginner
Posts: 1
Comments: 1

#2

I have just had the same issue with my Acronis 2012 version when I changed my email password and receive the error while parsing script file.  John Urish  how did you resolve this issue?  or did you?  

Beginner
Posts: 0
Comments: 1

#3

This bug still exists in 2016, what version is it fixed in?
Reassuring to see that the endless cycle of annual releases can't even sort a 30 second fix.

 

Legend
Posts: 81
Comments: 17545

#4

Paul, other than this topic from 3 years ago regarding a 7 year old (ATI 2012) application that had run for over 1000 iterations of the backup task, I have not seen any other reports of this issue in the forums.

ATI 2016 is over 3 years old and long out of support, so if no-one is reporting this 'bug' then I doubt that the Acronis developers have fixed it unless it came up in their own testing in the labs.

I personally have never had a single backup task that has run over a 1000 times without having needed to make changes and perhaps start with a fresh task.  My main backup task is currently on run _b61_ since I started using ATI 2019 after doing a clean install following participating in the beta testing for 2019 around June 2018.

There is a simple fix for this script issue - clone the script and start over afresh. 
The alternative, upgrade to ATI 2019, recreate the script issue and report it as a bug yourself or watch out for any announcement of the launch of the ATI 2020 Beta test program and participate and see if you can recreate the issue in that new version / report it if you can.