Skip to main content

TI2010 build 6053 - cannot find a partition with path...

Thread needs solution
Posts: 2
Comments: 4

I have been trying to get TI2010 working ever since I upgraded. (I upgraded due to 2009 having a sector reading problem or something, I forget... it was a while ago). It appears to run correctly when manually running an unscheduled task, but fails when running a scheduled task

with the following:

<?xml version="1.0" encoding="UTF-8" ?>
<log uuid="7C737509-85B8-41B9-AB61-152E24098A74" product="Acronis True Image Home" version="13.0" build="6053" task="ED08115F-3E6D-4620-9B53-409D3938AF54" task_name="System_C" >
	<event id="1" level="2" module="100" code="2" time="1260888241" message="Operation System_C started." />
	<event id="2" level="2" module="1" code="1024" time="1260888243" message="Child process has exited with code '0'." />
	<event id="3" level="2" module="100" code="134" time="1260888243" message="Execution of user command succeeded: C:\Chain2Gen\Acronis_PreProcessing_task.bat" />
	<event id="4" level="4" module="11" code="1004" time="1260888244" message="Cannot find a partition with path '\local\hd_sign(18838922)'." />
	<event id="5" level="4" module="100" code="5" time="1260888244" message="Operation has completed with errors." />

I have tried deleting and recreating the job, but that didn't help. The manual job I created is using the exact same hd_sign value, so obviously TI can find the drive when performing a manual operation.

I have attached an report

Attachment Size 375.47 KB
0 Users found this helpful
Posts: 172
Comments: 11125

is the manual job succeeding?

Look inside this link and see if it sheds any more light. You path may differ but check the file.
C:\Documents and Settings\All Users\Application Data\Acronis\TrueImageHome\Database\archives.xml

When you created the task and added the Chain2Gen task, what happens when you test it before saving the task?

What is the folder path you added to the user variables? Be sure there is no spaces between the = sign and the first part of the path; likewise no spaces after the path but before the return key.

Posts: 2
Comments: 4

This is the same issue that I have had over the last month or so since I have upgraded to 2010, and I only started playing with Chain2Gen this morning. The Chain2Gen task completes successfully, and I ran the other job to create the set0, set1, etc. folders afterwards.

I have my manual backup job pointing to E:\backups\full-on-demand\System_C_@date@.tib, here's my archives.xml file:

<?xml version="1.0" encoding="UTF-8" ?>
<ArchiveDatabase generator="40" ver_major="1" ver_minor="4">
		<ArchiveGroup Key="37" Name="System_C_12_15_2009">
				<Archive DataType="0" Flags="8" Id="14840871967202141929" Key="38" LinkedId="14840871967202141929" Type="0" Version="3">
						<Slice DataCreationTime="1260884476073" Id="C958DD87-535F-B5EB-1D86-A02D1EC401C2" Index="0" Key="39" Name="System_C_12_15_2009" ParentId="00000000-0000-0000-0000-000000000000" Rating="3" Type="0" VolumeCreationTime="1260884476073">
							<Description />
								<Volume Flags="1" Id="1664230687" Index="1" Key="40" Size="14222177280">

As you can see it never tried to make a group for the automatic process. Only the manual process that ran has a group in there.

Regular Poster
Posts: 11
Comments: 229

I can see from your ".tib" file name is NOT in folder "/set0"
this indicates a disconnect between what chain2gen is trying to do for you
and how you have defined your acronis job.

Trust me, its easier to recreate the job correctly
rather than trying to "fix" an existing job which is defined in-correctly
(even more so after that job has been run and created a .tib file).

step 1) launch acronis click the recovery tab find your existing archive(s) right click and delete.
step 2) launch windows explorer go to your chain2gen source code folder and
Make VERY sure that these two variables are correct.
These are the only two variables that can not readily be changed once
once this copy of chain2gen and acronis has started making .tib files.
(its ok to have several copies of chain2gen and acronis job pairs each for different devices/folders)

step 3) double click the file you just reviewed.
You should get a dialog box saying the the target folder string is now in your clipboard.

step 4) double click file Acronis_PreProcessing_task.bat
( this will create the folder tree if the do not yet exist)

step 5) clear the windows explorer address bar right click and "paste"
you should now be in an EMPTY folder which will be the target location of your backup.
if not please review the above steps on where you went wrong.
step 6) launch acronis re-create your backup job.
when it comes time to define where the .tib file should be created
Please use your clipboard (ctrl-v=paste) and suppy a file name.
I think this is where you went wrong the first time - you didn't use the clipboard/paste.
As for the actual filename my preference is to not use the @date feature
but rather simply a base name followed by a trailing dash"-"
the reason why subsequent incremental backups will get numbered
and it is very reassuring to see a set of file such as this...
you can tell at a glance all of the above files are a set.
and since there are no "gaps" in the numbers you "know" you have all the files of the set
the windows file date tells you when that specific .tib file was created.

step 7) when you define your acronis job on the "scheduling tab"
make sure you specify logonn credentials that is an admin for your pc.

I think the above steps should get you through your issues, let us know if it does not.

Posts: 2
Comments: 4

Let's just remove Chain2Gen from the discussion for now. I'm having the same problem whether I use it or not. The manual job that I mentioned is not using Chain2Gen, and just does an incremental backup to my full-on-demand backup folder that it is pointed to.

My main issue is the scheduled job not being able to find the source drive to backup from.

Here are my two job files. manual.tib.tis is the unscheduled job I ran to create a full backup at "E:\backups\full-on-demand\System_C_12_15_2009.tib". scheduled.tib.tis is the scheduled job I tried to have run to create the full / incremental backups at "E:\backups\set0\System_C-.tib"

Solution found!

I noticed you said provide credentials for a user account that is an admin on the computer. I am on a domain and do not have an admin account. I just tried adding myself to the admin group and it actually completed! I have made a local account and added it to the admin group as well and will give that a try in case my domain account gets booted from the local pc admin group when I next reboot.

Attachment Size 2.38 KB
Regular Poster
Posts: 11
Comments: 229

There are two places where authentication settings come into play.

1) when you define a backup locaction click for the .tib files click "browse" and find the desired folder.
in the menu ribbon you will see
"create new folder"
"create ftp connection"
"authentication settings"

click "authentication settings" and specify the username/password that CAN WRITE to the drive in question.
(and test your data entry via the button provided)

2) when you define your backup schedule there is a section of the panel for
"run with credentials"
make sure you specify a username/password which is an ADMINISTRATOR of the PC.
when you click "next" the your data entry on the username/password will be checked.
(I don't know if the checking also includes if the account you provided was an admin (or not) but it does check if you can logon with what was provided).

One would think that the two items above would address the permissions issue are seeing.

Posts: 2
Comments: 4

Thanks for the insight. It looks like all is well again, and I can forget about it!

Regular Poster
Posts: 11
Comments: 229

What you have looks right.
Glad its working.

Posts: 172
Comments: 11125

As oracledba stated, you can use Chain2Gen for many different backups tasks.

I have my master copy of Chain2Gen files in a parent folder and then created sub-folders for each task and copy a duplicate set of Chain2Gen files into each of the various sub-folders. One sub-folder for each backup task--usually named the same folder name as where the archives are to be stored. The only purpose of these sub-folders is to hold the Chain2Gen files because each set of files has different backup tasks and different parameters which must be kept separate. When adding the Acronis_PreProcessing_task.bat to the TrueImage Pre/Post processing task, just be sure and point to the pertinent sub-folder such as D::\Chain2Gen\E-backup1\Acronis_PreProcessing_task.bat or D:\Chain2Gen\E-backup2\Acronis_PreProcessing_task.bat etc.

Why not convert you manual job over to Chain2Gen as well. Remember, shorter is better when it comes to path length to your files. To run manually, you can use a Desktop shortcut; or open TI and right click on the task name and choose Start.