Skip to main content

Restore of incremental backup for Paralells VM (Windows 10 latest build) on Mac

Thread needs solution
Beginner
Posts: 1
Comments: 0

Don't know if any mac guy's or Acronis tech's have tried this yet or came across this, as I haven't seen any posts on this yet.

My VM development machine done the latest MS update and low and behold on restart game me the error of not able to find desktop folder in systemprofile directory. I've had this before and it cause a real headache, hence why I upgraded my ATI 2016 to 2017 subscription and started to use it again.

Anyway thought hey been backing up my VM every couple of days to protected development changes, I'll restore from a ATI backup. Restored the last backup done and ran the script provided to recreate the hdd header so that Parallels can boot the hd.

On restart of VM Windows 10 crashes with the message saying that cannot load winload it is either corrupted or missing. Checked the VM snapshots and the incremental ATI snapshot is there for that backup. So I tried going back to the snapshot (don't know if this snapshot is readable by Parallels?) and Parallels errors with the usual snapshot error code.

So I tried the original full backup restore with same procedures and it boots fine and I get the same terminal message for the header recreation as I did for the incremental restore.

MacBook-Pro:~ cybermechanic$ bash "/Applications/Acronis True Image.app/Contents/MacOS/recreate_pd_hdd.sh" "/VM/Backup/Windows 10 Dev.pvm"
/VM/Backup/Windows 10 Dev.pvm
Process disk [Windows 10 Dev-0.hdd]
  Source image = [/VM/Backup/Windows 10 Dev.pvm/Windows 10 Dev-0.hdd/Windows 10 Dev-0.hdd.0.{7d361290-1104-4838-9e7d-5761b3d80f43}.hds]
  Number of storages = 1
  Create: #
MacBook-Pro:~ cybermechanic$

I do know the process for incremental restore is Restore Full -> Restore Incremenatal. Could it be the script for recreating the header, just don't know.

There is only two weeks of backups and I have the development code on a separate virtual hd, so at present not much change have been done on the windows disk, but I would like to know what the issue with incremental restores are.

Any help would be much appreciated

Thanks

Jim

 

0 Users found this helpful
Forum Hero
Posts: 67
Comments: 7990

I've used the Mac appliation, but only with limited testing adn without parallels, bootcamp or VMware fusion.  For the most part, there isn't a lot of Mac forum action.  Since Acronis 2016/2017 have technical support for 2 years now, I would definitely open a support case with Acronis and send them the system reports and information so they can help out and/or identify any issues with this process that need to be resolved in the product.  Sorry, I can't be of any more help on this one :(

For what it's worth... if you can boot to Windows recovery media (an original installer of Windows) on the parallels side, you might try to run a startup repair.  I've found that sometimes, that is enough.  Othertimes, I have to go into the installer disc advanced command prompt and run bootrec commands (https://support.microsoft.com/en-us/kb/927392).  Sometimes that is enough.  Somtimes, I have to run those, reboot and go back in and then do a startup repair.

Last, in a few cases, I've had to use the advanced startup command prompt from the installer, mount the system parition with a drive letter in diskpart, then format that drive.  After formatting, reboot and go back into the installer advanced command prompt and then run startup repair (which usually says it failed), and then reboot and it finally boots.

Unforutnately, I don't have an exact method as the behavior and results seem to vary from system to system when dealing with UEFI installs.  Legacy/MBR was a lot easier to deal with as it was standardized across motherboards, but UEFI is anything but standardized and I am just now really coming to this realization after weeks of my own internal testing on my own home machine with a custom build on a Gigabyte Gaming 3 Z170X board and some very whacky and peculiar behavior that almost always requires me to short the CMOS jumpers to get it to properly detect drives after any type of recovery or clone.