Skip to main content

An attempt at a tutorial for creation of WinPE bootable media using Acronis WinPE ISO Builder from Plus Pack

Regular Poster
Posts: 2
Comments: 392

This is an attempt at a tutorial at creating WinPE bootable media.  I have tried to paste images into this editor without success, so I will try to attached JPEGs - sorry if this is not convenient, but I am new at this activity.

This tutorial assumes that the Plus Pack has been installed.  It also assumes that the Microsoft Windows AIK has been installed.  With only a minor (but important, I feel) exception, nothing is altered from a fresh installation.

Acronis very thoughtfully includes a version of the A43 File Management Utility with BartPE plug-in (which is also used for the WinPE build).  THIS IS A GREAT UTILITY, and can be updated to the latest release very easily.  If you don't think having the lastest A43 is important, just ignore this part of the tutorial.

Download the latest A43 from it's home on the web http://alterion.us/a43/ and install it.

Replace the A43-related files that appear in C:\Program Files\Acronis\TrueImageHome\BartPE\Files with the ones from the A43 installation. 

The A43 File Management Utility is very useful in the WinPE environment, which is command line based, and Windows Explorer won't run.  Again, you don't need to update these files - this can be done later when you start to enjoy customizing your WinPE build.

This initial tutorial is aimed at "Creating the PE 2 or PE 3 ISO with the plug-in from scratch" as mentioned on page 132 of the manual, section 15.3.2.  These procedures were completed on my "vintage" XP Pro SP3 machine using PE 2.

The first matter to take care of is creating the Windows PE Build Environment.  This is done via command line interface.  As this build will not include any customization, creating the build environment will be the ONLY command line activity required (in case you have an aversion to CLI).

My Start Menu has a Windows PE Tools Command Prompt entry, but you can also get this command prompt by Start->All Programs->Microsoft Windows AIK->Windows PE Tools Command Prompt.  You are at the proper folder and do not have to enter "cd Program Files\Windows AIK\Tools\PETools\" as stated in the manual.

You do have to run the copype.cmd script as shown.  You can look at the command script if you want to make sure that it is doing nothing nefarious. 

Now the build environment is created.  The folder structure is show at the below picture.

No more CLI!  Now for the Acronis WinPE ISO Builder.

Again, I have a Start Menu item Acronis WinPE ISO Builder, but this can be reached by Start->All Programs->Acronis->Plus Pack for True Image Home 2010->Acronis WinPE ISO Builder.  The opening screen is shown as below. Select Next to continue.

Select the path as shown in then next screen.  Otherwise you will get either an error message or the next screen will be different.  Select Next to continue.

If all is well you should get the next screen. Make sure the selection "Add components and build an ISO" is the active one with the radio button.  Select Next to continue.

The next screen is shown on the below picture.  You shouldn't have to change anything here is the preceding steps were followed - what is shown is the default.  Select Next to continue.

Unlike what is stated in the manual, you don't have to (or are even given the option to) specify the path for the Acronis plug-in file or look for anything in the registry.  It is by default C:\Program Files\Acronis\TrueImageHome\BartPE.  Make sure the files are there before continuing.

The summary action screen appears as shown at the next picture..  Select Next to continue.

You will see a variety of little windows pop up with clocks, progress bars, and messages similar to Copying Source WIM-file..., Mounting WIM-File..., Updating WIN-File components..., Unmounting WIM-File..., Building ISO Image... until the reward window appears, shown as following:

Now the C:\winpe_x86\ISO\ folder has a newly minted AcronisMedia.ISO file as shown.  Burn this to a CD (I use Nero), and you have a WinPE bootable disk.

As stated in the manual, Acronis True Image Home starts automatically.

A few notes about the base WinPE environment:

If WinPE can't detect video settings (and it can't on my system), it uses a resolution of 640x480 pixels.  This is tolerable, and I have found a way to fix this, but not in this basic WinPE build.

No 16-bit (DOS) applications will run in WinPE, because Windows on Windows is not supported.

Once you close Acronis True Image Home, you will wind up in a command prompt window.  Find you way to the A43 folder (under trueimagehome) and start A43 to begin nosing around.

To get out of A43, enter "exit" at the command line prompt, and you system *should* reboot.

VBScript support is inherent in the WinPE environment.  Support for Windows Script Host can be added (I have done this).

You can also add you own tools to a WinPE build (I have done this too, such as an universal file editor and command line utility for changing screen resolution).  If there is any interest, and I can find the time, I can put together tutorials showing how to do this.  I see that I can attach PowerPoint files - I'll have to see if this may work.

I hope this inital tutorial helps someone somewhere.  I see great potential for the WinPE environment beyond as a platform for True Image Home, will very flexible functionality for customized recovery needs.

An addition from Acronis Forum Moderator:

Here are the links to Windows AIKs (Automated Installation Kits):

AIK for Windows XP and Windows Vista (PE 2.0)
AIK for Windows Vista SP1 and Windows Server 2008 (PE 2.1)
AIK for Windows 7 (PE 3.0)

Forum Member
Posts: 6
Comments: 20

Top

Thank you James for spending the time obtaining this info. You deserve the "MVP" moniker. Whether it works or not I appreciate all you have done. I'll let you know what happens.

Forum Member
Posts: 6
Comments: 20

Top

You're awesome... I can now see the Raid but the the DISM /Add-Driver for the Intel .inf failed for some strange error which I thoroughly didn't understand. I attached the portion of the DISM.LOG file where the error occured. Not sure if you can
understand it... anyway, you have done enough and I greatly appreciate it.

I will try again tomorrow morning... who knows. Have a great night James.

Forum Star
Posts: 46
Comments: 2760

Top

Attached is the full Windows 7 32 bit driver package for the Intel Gigabit cards. I may not have included some files that DISM was looking for. There are more drivers than you need (6 in total), but you can install them all and it will not take very much space on disk or in memory.

James

Edit: Attached is a new zip file that contains just your NIC drivers (I tested the injection with this set). There still may be some extra .dll files, as I can't tell which belong to the driver.

Attachment Size
113215-104020.zip 1.4 MB
113215-104023.zip 354.95 KB
Forum Member
Posts: 6
Comments: 20

Top

Thanks again. I will try them this morning.

Forum Member
Posts: 6
Comments: 20

Top

Hi James... I tried the new driver "set" and the driver added successfully BUT after booting the rescue disk, there was no network.
Unless you have other ideas, i'm going to leave it as is. My backups are on the Raid anyway, and that is working now thanks to you. I just wanted the network connection just in case I needed access from other PCs.

Again thank you... Bob

Forum Star
Posts: 46
Comments: 2760

Top

In the WinPE environment, you have to use the "net" command line utility (from the WinPE command window) to map the network shares as drive letters, or tell Acronis to use the UNC named path including the server name and share name and will have to provide network credentials. The drive mapping using the net use" commands seems to work best for me, as then you can use the drive letter as the source or destination in True Image. There is no "network" listed in the True Image program that runs from the WinPE environment.

See: http://www.rm.com/Support/TechnicalArticle.asp?cref=TEC1287003

Forum Member
Posts: 6
Comments: 20

Top

Didn't know that. I was expecting to see a "Network" connection. I will try and let you know.

Forum Member
Posts: 6
Comments: 20

Top

I can see the network and Raid. What could be better. Thanks James for all your help in this.
Hope I can help you out sometime...

Forum Star
Posts: 46
Comments: 2760

Top

A fully automated WinPE creation process with the appropriate drivers loaded specific to your system.......That would be better......