Skip to main content

VERY slow backup SOLVED - for Win7 64bit and External Hard Drive (firewire)

Thread needs solution
Beginner
Posts: 1
Comments: 0

I spent a week trying to solve why my partition backup to an external hard drive was extremely slow (estimated 9 days for approx 475 GB on the drive) and I finally found the answer.

(fyi the answer was NOT applying the lastest snapapi drivers)

I found this by googling and it reduced the time from 9 days to 8 hours and the backup completed successfully. Hope this helps. --------------------------------------------------------------------------------------------------------------------------------

The default Windows settings for FireWire-connected drives can reduce your External drive performance by as much as 90%. This problem is easily corrected, just follow these instructions:

1. Open "My Computer" or "Computer" from your (Start) Menu or Button.
2. Right-click the external Hard disk drive from the list and select "properties"
3. Click the "Hardware" tab.
4. Highlight the drive your having problems with from the drive list and click on "Properties".
5. Click on the “Policies” tab.
6. You will see two radio buttons - "Optimize for quick removal" and "optimize for performance".
7. If not selected, select "Optimize for performance" and click on "OK". If running Vista or Windows 7 also check "enable write caching on the disk".
8. Click on "OK" and exit.

Lighting speeds should now be reached.

This problem can affect XP, Vista or Windows 7. It may improve performance for any drive connected via FireWire.

1 Users found this helpful
Regular Poster
Posts: 24
Comments: 185

#1

Hello April,

Thanks for sharing your findings with out community.

I am moving this topic to Best practices.

Andrey. 

Ray
Forum Member
Posts: 10
Comments: 86

#2

I'm using Windows 7 Professional. After step 4, I had to click "Change Settings."

4. Highlight the drive your having problems with from the drive list and click on "Properties".
4a. Click "Change Settings."
5. Click on the “Policies” tab.

P.S. I'm using Acronis 2010 because I hate the UI in 2011 and I understand it's much the same in 2012. Backing up to another internal drive, I get a speed of 3,900 MB/min for a 150GB file. Backing up to a USB drive (My Book USB 2.0) I get 1,644 MB for roughly the same file. Total times 38 minutes and 91 minutes. The internal drive has Enable write caching selected. My Book drive has Quick Removal selected rather than Better Performance and I didn't change it as it's fast enough.

Beginner
Posts: 3
Comments: 6

#3

This info is great up to a point, but take a look at this:

http://kb.acronis.com/content/4071

It appears that the optimize for performance tweak will create some "Device is not ready" errors, at least for USB drives.

Just thought I would add that to the discussion.

Beginner
Posts: 0
Comments: 1

#4

Your solution did the trick!  It worked on Windows 10. Thanks!!!!!!!