Skip to main content

Backup Raspberry Pi SD-Karte mit ATI2018 unter Windows 10

Thread needs solution
Regular Poster
Posts: 10
Comments: 180

Ich mache ein Backup meiner Paspberry Pi SD-Karte mit einem USB-Kartenleser unter Windows 10. Die Option, bestimmte Dateien nicht ins Backup zu übernehmen, ist ausgeschaltet. Das Backup läuft ohne Fehlermeldung durch. Auch das Recovery auf die SD-Karte läuft ohne Fehlermeldung durch.

Auf einem Linux-Rechner sind beide Partitionen der SD-Karte mit dem zurückgespielten Backup lesbar, es scheinen keine Dateien zu fehlen.

Wenn ich diese SD-Karte aber wieder in den Raspberry Pi einstecke, funktioniert der Pi nicht. Er scheint nicht mal zu booten.

Hat jemand einen Tipp, wie man funktionierende Backups mit ATI erstellen und zurücksichern kann?

Anmerkung: Backups / Zurücksichern mit Win32DiskImager funktioniert. Das dauert aber länger und die Sicherungsdateien sind viel größer. Deshalb möchte ich ATI2018 verwenden.

0 Users found this helpful
Forum Hero
Posts: 87
Comments: 7546

Wurde ein Laufwerksbackup ohne Ausschließungen erstellt?

Beim Wiederherstellen dann mit "MBR und Track0" und "Disk-Signatur wiederherstellen" (falls verfügbar) angehakt wiederhergestellt?

Regular Poster
Posts: 10
Comments: 180

Alle Ausschließungen wurden beim Erstellen des Backups abgewählt.

Die Auswahlen "MBR und Track0" und "Disk-Signatur wiederherstellen" gibt es nicht beim Wiederherstellen der SD-Karte.

Auch ein Sektor-für-Sektor-Wiederherstellen bringt nichts.

 

 

Regular Poster
Posts: 10
Comments: 180

Hier noch ein paar Zahlen, die zeigen, warum ATI Backups interessant wären (für eine 32 GByte SD-Karte) im Vergleich zu dem gebräuchlichen Win32Diskimager:

 

Win32Diskimager Acronis
Größe des Backups  32 GByte  3 GByte
Größe mit PiShrink 8 GByte  entfällt
Zeit für das Erstellen eines Backups   7 min 30 s 2 min
Zeit für Recovery  8 min 6 min 30

 

Regular Poster
Posts: 10
Comments: 180

Ich habe mittlerweile Acronis TrueImage 2020 installiert und getestet.

Damit startet das Backup einer SD-Karte, kommt aber nicht zum Ende - ich habe bei einer 32 GB Karte über 15 Minuten gewartet.

Also eher eine Verschlechterung der Situation durch ATI2020

 

Forum Moderator
Posts: 242
Comments: 7045

Hallo Berti,

stellen Sie bitte sicher, dass die CPU-Architektur und das Betriebssystem von Acronis True Image unterstützt sind, z.B. bei ARM and ARM64 werden die Sicherung und erfolgreiche Wiederherstellung nicht garantiert. 

Hier finden Sie mehr Information 62562: Acronis True Image: Nicht unterstützte CPU und Betriebssysteme

Regular Poster
Posts: 10
Comments: 180

Hallo Ekaterina,

ich fürchte, Sie haben überhaupt nicht verstanden, worum es hier geht.

ATI2020 läuft auf einem Windows 10 Rechner. Es soll ein Backup einer SD-Speicherkarte gemacht werden, die 2 Partitionen enthält - eine FAT32 und eine Ext4 formatierte. ATI2020 ist für beide Formate geeignet (jedenfalls laut Acronis Aussage in https://kb.acronis.com/content/6045). Trotzdem kann man mit ATI2020 kein Backup einer solchen SD-Karte erstellen.

Das ist eine Fehlfunktion von ATI2020.

Beginner
Posts: 0
Comments: 1

Hallo,

ich habe exakt die gleiche Frage. Ist denn nun ein Backup der Raspberry Pi Partitionen unter Windows oder mit der Acronis Boot CD möglich? Welche Version kann das?

Danke !

Forum Hero
Posts: 87
Comments: 7546

Ich habe ein Paar Versuche mit einem Linux basiertem ATI 2019 Bootmedium gemacht.

Beim ersten Versuch wurde die Original Raspberry Pi 4B SanDisk Ultra microSDHC UHS-I 16GB Micro SD Karte in einem USB 3.0 Adapter gesteckt.

Das System von der Linux basiertem ATI 2019 Boot CD (Aus dem Acronis Benutzeraccount heruntergeladen) im Legacy Mode gestartet und wenn vollständig geladen, den Adapter in einen USB 3.0 Port gesteckt.

Nach einer kurzen Wartezeit ein Laufwerksbackup der Micro SD Karte erstellt (ohne "Sektor für Sektor" angehakt).

Dieses Laufwerksbackup wurde dann später von der Linux basiertem ATI 2019 Boot CD aus, im Legacy Mode auf eine neue leere Baugleiche SD Karte mit "Disk-Signatur wiederherstellen" angehakt wiederhergestellt.

Das Raspberry Pi bootete damit problemlos.

Beim 2. Versuch wurde die SD Karte mit "Neues Laufwerk hinzufügen" mit Partitionsstil "MBR" neu initialisiert und danach mit dem Laufwerksbackup und "Disk-Signatur wiederherstellen" wiederhergestellt. Auch mit dieser SD Karte bootete das Raspberry Pi 4.

Also, wichtig ist das Bootmedium im Legacy Mode zu starten und "Disk-Signatur wiederherstellen" beim wiederherstellen anzuhaken.

(Leider kann ich zur Zeit keine Bilder hochladen)

EDIT: Ein Versuch mit einem Linux basiertem ATI 2020 Bootmedium war auch erfolgreich, allerdings kam mir die Backup- und Wiederherstellungsdauer deutlich langsamer vor, als mit ATI 2019.

Regular Poster
Posts: 10
Comments: 180

Danke G. Uphoff für´s testen.

Ich fürchte allerdings, daß bei dieser Prozedur der Zeitvorteil von Acronis gegen Win32Diskimager verloren geht - siehe Post #3.

Ich muß ja Windows herunterfahren, vom Linux Stick booten und später wieder herunterfahren, dann wieder Windows booten und benutzte Programme starten - alles dauert und ist nicht gerade elegant.

Forum Member
Posts: 7
Comments: 47

Sodele, stehe jetzt vor der gleichen Aufgabe und habe daher diesen Thread hier gefunden.

- was bedeutet Legacy Mode... bedeutet das den "nicht-UEFI-Mode" ? Wenn nein, was dann ?

Habe aus meinem ATI 2020 heraus den "Rescue Media Builder" angestoßen und dann über "Erweitert" ein Linux-basiertes Medium über "Schließen Sie Ihr externes Laufwerk an" auf einem USB-Drive erstellt (also keine ISO-Datei). Damit dann mit "nicht-UEFI" gebootet und mittels ATI 64-bit ein Laufwerksbackup gemacht (ohne "Sektor für Sektor").

Sollte dass dann funktionieren?

Forum Hero
Posts: 87
Comments: 7546

Hallo NoPlayBack,

Ja, das sollte so funktionieren.

"Legacy Mode" = "Bios Mode", oder "nicht UEFI Mode". (Im UEFI Mode gibt es die "Disk-Signatur wiederherstellen" Option nicht.)

Attachment Size
607037-341074.pdf 2.01 MB
607037-341075.pdf 1.81 MB
Forum Member
Posts: 7
Comments: 47

Sodele, nach langem Hin- und Her melde ich mich mal mit meinen Ergebnissen:

ATI hat nicht funktioniert. Ich habe die mitgelieferte SDCard gesichert und dann auf eine Karte gleicher Größe wieder hergestellt. Die SDCard bringt den Raspberry dann in eine Bootschleife und kommt da nicht mehr raus.

Auch auf einer größeren Karte (was eigentlich mein Ziel war) funktionierte es nicht.

Was mich überrascht hat war das selbst, wenn ich gesagt hatte, exakt gleiche Wiederherstellung durchzuführen und nicht auch noch Größenänderungen, ATI sich dazu entschieden hat, die Partitionen zu vergrößern damit der komplette SDCard-Bereich genutzt wird.

Ich habe mehrere veschiedene Vorgehensweisen getestet, ATI hat es nicht geschafft.

Was funktioniert hat war ein Tool was oft im Bereich von Raspberry erwähnt wird: Win32DiskImager. Das Teil ist zwar langsam und sichert auch die komplette Größe der SDCard, aber es läuft. Was mich beunruhigt hatte war dass meine SDCard 2 Partitionen und damit 2 Laufwerkbuchstaben erzeugt... aber egal welchen Buchstaben man wählt, diese SW sichert einfach die komplette SDCard.

Schade dass es nicht mit ATI geklappt hat (schneller und kleinere Datei)... und eigentlich auch komisch, aber ich wüsste nicht mehr was ich da noch anders machen könnte. Auch andere Lesegeräte oder andere SDCard hatte ich probiert.

Wenn da jemand das nachvollziehen will und den Grund herausfinden will warum das nicht funktioniert, dann könnte ich ja das Image der SDCard zur Verfügung stellen...

Forum Member
Posts: 7
Comments: 47

Lange her... aber leider immer noch nicht gelöst.

Habe jetzt noch einmal die Links von oben gelesen:

62562: Acronis True Image: Nicht unterstützte CPU und Betriebssysteme

https://kb.acronis.com/content/6045)

 

in denen ja eigentlich eher behauptet wird das sollte funktionieren.

Habe gerade eine SSD eines Raspberry gesichert, was anstandslos funktioniert... aber das erzeugt Restore ist leider nicht bootfähig. Daten scheinen drauf zu sein.

Mich würde jetzt hier doch mal root-cause interessieren...

Forum Hero
Posts: 87
Comments: 7546

Hallo NoPlayBack,

Um bootfähig zu sein, muss die "Disk-Signatur" wiederhergestellt werden. Dazu muss die SD Karte oder SSD mit Partitionsstiel "MBR" formatiert sein, der Inhalt des Backup-Archivs muss zur SD Karte, oder SSD passen (am besten gleiche, oder Baugleiche SD Karten, SSDs und Festplatten verwenden). Sollte die SD Karte oder SSD größer sein, wird das wiederherstellen der "Disk-Signatur" nichts nützen.

Ich verwende nur Acronis True Image und ACPHO und damit kann ich mein Raspberry PI 4b problemlos sichern und wiederherstellen.

Ich habe ein Paar Versuche mit einem Linux basiertem ACPHO Bootmedium gemacht.

Bei den Versuchen wurde die Original Raspberry Pi 4B SanDisk Ultra microSDHC UHS-I 16GB Micro SD Karte in einem USB 3.0 Adapter gesteckt. Eine Samsung 830 Sata SSD in einem externenen USB 3.0 Gehäuse eingebaut.

Das System von der Linux basiertem ACPHO Boot CD (Aus dem Acronis Benutzeraccount heruntergeladen) im Legacy Mode gestartet und wenn vollständig geladen, den Adapter in einen USB 3.0 Port gesteckt.

Forum Member
Posts: 7
Comments: 47

Jupp... ähnliche Hinweise hattest du ja oben bereits geschrieben... die hatte ich damals punktgenau nachvollzogen und es hat leider nix gebracht.

Neu wäre jetzt die Benutzung von ACPHO... muss ich wohl mal testen...

 

ups... ich kann ja nur Notfall-CDs laden von Produkten und Versionen die ich auch lizensiert habe... daher wird das wohl nix mit dem Test. Mit ATI 2020 hatte ich ja genau das getestet und war gescheitert...

Forum Hero
Posts: 87
Comments: 7546

Hallo NoPlayBack,

Wurde schon mal versucht, die SD Karte oder SSD nicht zu löschen, sondern nur die EXT4 Partition wiederherzustellen? (Die Disk-Signatur bleibt dann erhalten)

Attachment Size
612213-357750.gif 281.83 KB
Forum Member
Posts: 7
Comments: 47

Eben probiert... mit Bootmedium von ATI 2020, nur ext4 zurück.

Auf dem Bildschirm des Raspberry: "Failed to start".

Startet nicht mehr.

Forum Hero
Posts: 87
Comments: 7546

Hallo NoPlayBack,

Schade, bei mir funktionieren alle vorgestellten Methoden ausnahmslos immer.

Wird das Bootmedium auch wirklich im "Legacy Mode", "Bios Mode", nicht im "UEFI Mode" gestartet?

Attachment Size
612306-358109.gif 128.17 KB
Forum Member
Posts: 7
Comments: 47

Ja.... ich habe beim Boot-Menü des Rechners das Medium, auf dem ATI-Notfallprogramm installiert ist, immer 2 * aufgelistet. Eines sagt UEFI im Namen, ich wähle das andere.