Skip to main content

Fehler bei Backup einer Hyper-V-VM

Thread needs solution
Beginner
Posts: 1
Comments: 0

Hallo zusammen.

Ich habe hier ein Problem mit dem Backup einer VM in einer Hyper-V-Umgebung. Kurz zum System:
Zwei Windows Server 2012 Std. als Hyper-V-Hosts. Kein gemeinsames Speichersystem. Beide mit Acronis versehen, einer der beiden Server ist der AMS und Storage-Node.
Anfänglich waren alle VMS auf einem Server (der mit dem AMS), da wir noch in der Migrationsphase waren. Alle Backups liefen sauber durch. Jede virt. Maschine hat einen eigenen Backup-Task.
Nachdem dann der zweie Hyper-V in Betrieb ging, habe ich mehrere VMs auf diesen verschoben. Lief alles problemlos. Allerdings funktioniert seit dem das Backup einer VM (Exchange) nicht mehr (Fehlermeldung unten). Die andern Backups laufen.
Gestern hatte ich dann das Update 1 von Acronis eingespielt. Danach lief kein einziger Backupjob mehr. Ein manuelles Starten des Task bewirkte gar nicht. Keine Fehlermeldung...nichts. Heute morgen habe ich von den alten Tasks Klone erstellt...die funktionieren (!?!?!)...außer das Backup vom Exchange. Momentan sichere ich den Exchange erst mal aus der VM heraus per Windows Server Sicherung. Besser als gar nichts.
Ich habe nun schon eine Weile gegoogelt und hier im Forum gesucht. Die angegeben Fehlerquellen schließe ich mal aus (kein freier Speicher für Snapschots, fehlende Rechte des Accounts mit dem Acronis läuft, Moult-Volume-Snapshot an oder aus, VSS-Provider gewechselt). Hat noch jemand eine Idee? Wieso kann er nicht auf die VHD zugreifen? Und auch nur auf die eine VHD (der Exchange hat zwei Platten...eine als System eine für die Exchange-DBs, die mit den DBs macht das Problem).
Ein Zurückverschieben auf den ersten Hyper-V hat auch nichts gebracht...gleiches Fehlerbild. :-(

Danke im Voraus.

Fehlermedung:

ProtectCommand: Ausführen des Befehls fehlgeschlagen.
Zusätzliche Info:
--------------------
Fehlercode: 41
Module: 307
LineInfo: e6792a5ee190dda6
Felder: $module : agent_protection_addon_vs_37975
Nachricht: ProtectCommand: Ausführen des Befehls fehlgeschlagen.
--------------------
Fehlercode: 32834
Module: 114
LineInfo: c35c04057128fda9
Felder: $module : disk_bundle_vs_37975
Nachricht: Backup von virtuellen Maschinen ist fehlgeschlagen.
--------------------
Fehlercode: 32853
Module: 114
LineInfo: c35c04057128fdeb
Felder: $module : disk_bundle_vs_37975
Nachricht: Es wurden nicht alle virtuellen Maschinen per Backup gesichert.
--------------------
Fehlercode: 32852
Module: 114
LineInfo: c35c04057128fe3d
Felder: $module : disk_bundle_vs_37975
Nachricht: Backup der virtuellen Maschine 'DUP-EX-01' fehlgeschlagen.
--------------------
Fehlercode: 32786
Module: 114
LineInfo: 28314c961de7d2c2
Felder: $module : disk_bundle_vs_37975
Nachricht: Vorbereitung auf das Backup fehlgeschlagen.
--------------------
Fehlercode: 3
Module: 329
LineInfo: 1cd98aae889424f9
Felder: $module : disk_bundle_vs_37975
Nachricht: Backup ist fehlgeschlagen.
--------------------
Fehlercode: 1060
Module: 1
LineInfo: d1ab7fa1e56ec6ca
Felder: $module : disk_bundle_vs_37975
Nachricht:
--------------------
Fehlercode: 13
Module: 149
LineInfo: d1ab7fa1e56ec81c
Felder: $module : disk_bundle_vs_37975
Nachricht: Ausführen der angeforderten Aktion fehlgeschlagen.
--------------------
Fehlercode: 236
Module: 16
LineInfo: 7bb42efe3c733241
Felder: $module : disk_bundle_vs_37975
Nachricht: Interner Fehler: Versuch auf emulierte Festplatte für ein nicht initialisiertes Objekt zuzugreifen
--------------------
Fehlercode: 94
Module: 83
LineInfo: 383ffdb092990e22
Felder: $module : hv_srv_vs_37975
Nachricht: Öffnen der virtuellen Laufwerksdatei 'D:\vms\dup-ex-01\Virtual Hard Disks\DUP-EX-01_2.vhdx' fehlgeschlagen.
--------------------
Fehlercode: 212
Module: 83
LineInfo: 383ffdb092990dd9
Felder: $module : hv_srv_vs_37975
Nachricht: Erstellen eines Multi-Volume-Snapshot fehlgeschlagen, wo die Dateien gespeichert sind:
D: \vms\dup-ex-01 (Speicherort der virtuellen Maschinen-Datei),
D: \vms\dup-ex-01\ (Speicherort der virtuellen Maschinen-Snapshot-Datei),
D: \vms\dup-ex-01\Virtual Hard Disks\DUP-EX-01.vhdx (Speicherort der virtuellen Laufwerks-Datei),
D: \vms\dup-ex-01\Virtual Hard Disks\DUP-EX-01_2.vhdx (Speicherort der virtuellen Laufwerks-Datei).
--------------------
Fehlercode: 207
Module: 83
LineInfo: 383ffdb092990dca
Felder: $module : hv_srv_vs_37975
Nachricht: Mounten des Volume-Snapshots fehlgeschlagen.
--------------------
Fehlercode: 33
Module: 7
LineInfo: e24f93d0b8d8c9c7
Felder: $module : hv_srv_vs_37975
Nachricht: Erstellen des Volume-Snapshots fehlgeschlagen.
--------------------
Fehlercode: 50242
Module: 16
LineInfo: 14181c22ef45b0f6
Felder: $module : hv_srv_vs_37975
Nachricht: Erstellung des Volume-Snapshot konnte nicht gestartet werden.
--------------------
Fehlercode: 50281
Module: 16
LineInfo: 14181c22ef45a9ed
Felder: $module : hv_srv_vs_37975
Nachricht: Der VSS Writer ist aufgrund eines Fehlers fehlgeschlagen, der vermutlich nicht passieren würde, wenn der komplette Backup-Prozess, Recovery-Prozess oder Schattenkopieerstellungsprozess neu gestartet worden wäre. Bitte warten Sie 10 Minuten und wiederholen Sie dann die Aktion.
--------------------

0 Users found this helpful
Beginner
Posts: 0
Comments: 5

#1

Hi,
ich habe die gleichen Fehlermeldungen in unserer Hyper-V Umgebung: siehe hier unten.
Anscheinend macht Acronis sowohl bei mir als auch bei dir Probleme mit den neuen *.vhdx - Dateien!
Ich werde jetzt alle vhdx-Dateien wieder in vhd konvertieren und dann wird das Problem höchstwahrscheinlich gelöst sein.
Bis du mit Fehleranalyse irgendwie weitergekommen?

ProtectCommand: Ausführen des Befehls fehlgeschlagen.
Zusätzliche Info:
--------------------
Fehlercode: 41
Module: 307
LineInfo: e6792a5ee190dda6
Felder: $module : agent_protection_addon_vs_37975
Nachricht: ProtectCommand: Ausführen des Befehls fehlgeschlagen.
--------------------
Fehlercode: 32834
Module: 114
LineInfo: c35c04057128fda9
Felder: $module : disk_bundle_vs_37975
Nachricht: Backup von virtuellen Maschinen ist fehlgeschlagen.
--------------------
Fehlercode: 32853
Module: 114
LineInfo: c35c04057128fdeb
Felder: $module : disk_bundle_vs_37975
Nachricht: Es wurden nicht alle virtuellen Maschinen per Backup gesichert.
--------------------
Fehlercode: 32852
Module: 114
LineInfo: c35c04057128fe3d
Felder: $module : disk_bundle_vs_37975
Nachricht: Backup der virtuellen Maschine 'xxxSRV' fehlgeschlagen.
--------------------
Fehlercode: 32786
Module: 114
LineInfo: 28314c961de7d2c2
Felder: $module : disk_bundle_vs_37975
Nachricht: Vorbereitung auf das Backup fehlgeschlagen.
--------------------
Fehlercode: 3
Module: 329
LineInfo: 1cd98aae889424f9
Felder: $module : disk_bundle_vs_37975
Nachricht: Backup ist fehlgeschlagen.
--------------------
Fehlercode: 1060
Module: 1
LineInfo: d1ab7fa1e56ec6ca
Felder: $module : disk_bundle_vs_37975
Nachricht:
--------------------
Fehlercode: 13
Module: 149
LineInfo: d1ab7fa1e56ec81c
Felder: $module : disk_bundle_vs_37975
Nachricht: Ausführen der angeforderten Aktion fehlgeschlagen.
--------------------
Fehlercode: 236
Module: 16
LineInfo: 7bb42efe3c733241
Felder: $module : disk_bundle_vs_37975
Nachricht: Interner Fehler: Versuch auf emulierte Festplatte für ein nicht initialisiertes Objekt zuzugreifen
--------------------
Fehlercode: 94
Module: 83
LineInfo: 383ffdb092990e22
Felder: $module : hv_srv_vs_37975
Nachricht: Öffnen der virtuellen Laufwerksdatei 'D:\Hyper-V\xxxSRV\xxxsrv-d-neu.vhdx' fehlgeschlagen.
--------------------
Fehlercode: 212
Module: 83
LineInfo: 383ffdb092990dd9
Felder: $module : hv_srv_vs_37975
Nachricht: Erstellen eines Multi-Volume-Snapshot fehlgeschlagen, wo die Dateien gespeichert sind:
D:\Hyper-V\xxxSRV\xxxSRV (Speicherort der virtuellen Maschinen-Datei),
D:\Hyper-V\xxxSRV\xxxSRV (Speicherort der virtuellen Maschinen-Snapshot-Datei),
D:\Hyper-V\xxxSRV\xxxsrv-c-neu.vhdx (Speicherort der virtuellen Laufwerks-Datei),
D:\Hyper-V\xxxSRV\xxxsrv-d-neu.vhdx (Speicherort der virtuellen Laufwerks-Datei).
--------------------
Fehlercode: 207
Module: 83
LineInfo: 383ffdb092990dca
Felder: $module : hv_srv_vs_37975
Nachricht: Mounten des Volume-Snapshots fehlgeschlagen.
--------------------
Fehlercode: 33
Module: 7
LineInfo: e24f93d0b8d8c9c7
Felder: $module : hv_srv_vs_37975
Nachricht: Erstellen des Volume-Snapshots fehlgeschlagen.
--------------------
Fehlercode: 50242
Module: 16
LineInfo: 14181c22ef45b0f6
Felder: $module : hv_srv_vs_37975
Nachricht: Erstellung des Volume-Snapshot konnte nicht gestartet werden.
--------------------
Fehlercode: 50281
Module: 16
LineInfo: 14181c22ef45a9ed
Felder: $module : hv_srv_vs_37975
Nachricht: Der VSS Writer ist aufgrund eines Fehlers fehlgeschlagen, der vermutlich nicht passieren würde, wenn der komplette Backup-Prozess, Recovery-Prozess oder Schattenkopieerstellungsprozess neu gestartet worden wäre. Bitte warten Sie 10 Minuten und wiederholen Sie dann die Aktion.
--------------------

Beginner
Posts: 0
Comments: 5

#2

Habe es gerade mit vhd-Dateien getestet: es kommt leider die gleiche Fehlermeldung!

Beginner
Posts: 0
Comments: 1

#3

Ich habe seit gut einem halben Jahr den selben Fehler.
Hyper-V Clusterumgebung mit Win 2012 Servern.
Nach drei Monaten Acronis Support wurde Microsoft die Schuld dafür gegeben...
Sicherung mit Agent aus der VM funktioniert. Nur mit der Virtual Edition geht es nicht.

Beginner
Posts: 0
Comments: 3

#4

Hallo,

seit ungefähr einer Woche hat ein Kunde dieselben Fehlermeldungen. Nur der erste Fehlercode ist anders.
Fehlercode: 61
Module: 309
LineInfo: 4a8728dc8a1c950f
Felder: $module : service_process_vs_37975
Nachricht: Befehl 'Backup' ist fehlgeschlagen.

Sonst sind die Meldungen identisch!

Der Hyper-V Server (HP ProLiant ML350p G8, Windows 2012 Server) ist funkelnagelneu, im Moment läuft nur eine VM (Windows 2008 SBS) mit einer vhd-Datei (ca. 360 GB). Build ist aktuell. Sicherungen erfolgen auf einen Fujitsu Celvin Q802 NAS-Server. Sicherungen innerhalb der VM funktionieren. Die Sicherung der Systempartition des Hyper-V Servers läuft problemlos. Die Sicherung der VM funktioniert wenn der Start manuell erfolgt (bisher zwei mal). Der Acronis VSS ist gelöscht. Snapshot Provider ist "Software - System Provider". Einstellungen in der Registry für SnapshotStorage sind angepasst. Multi-Volume-Snapshot ist im Auftrag deaktiviert, deswegen wundert mich auch der Fehlercode 212.

Der Fall ist schon bei Acronis, bisher habe ich noch kein Feedback bekommen. Ein anderer Kunde hat ein vergleichbares System, bei dem (zum Glück) das Problem nicht auftritt.

Beginner
Posts: 0
Comments: 5

#5

Ich vermute stark, dass die Problematik an Windows Sicherheitsupdates liegt. Die ersten Server 2012, die ich mit Hyper-V + Acronis 11.5 im April 2013 installiert habe, laufen auch bis jetzt problemlos. Allerdings habe ich auf den Servern ab April 2013 keine Sicherheitsupdates mehr gemacht.
Nur die neuesten Server ab September-Oktober 2013m mit den neuesten Updates machen Probleme!

Beginner
Posts: 0
Comments: 3

#6

Das mit den Updates kann ich so nicht bestätigen. Das vergleichbare System (s.o.) hat alle Updates von August bis Oktober 2013 und läuft. Und ich halte es für bedenklich auf einem System mit Verbindung zum Internet keine Sicherheitsupdates zu installieren.

Beginner
Posts: 0
Comments: 5

#7

Alle 3 Server, die ich im April 2013 ohne weiteren Updates installiert habe, laufen ohne Probleme mit Acronis 11.5 Build 11.5.37608
Die hardwaremäßig gleichen Server mit den gleichen Images und aktuellsten Updates + Acronis 11.5 Build 11.5.37975, machen ab Oktober 2013
die obengenannten Probleme.
Ich habe etwas andere Politik: alle Hyper-V Server befinden sich im externen Netzwerk: standalone, nicht in der Domäne bzw. nicht mit dem Internet verbunden. Die Hyper-V Server machen nur 2 Aufgaben: Hyper-V und Acronis-Backup. Die Kommunikation mit Außenwelt (VPN, Zeitsynchronisierung, E-Mail-Benachrichtigung usw.) wird mit statischen Routen realisiert.

Beginner
Posts: 0
Comments: 3

#8

Seit einer Woche läuft die Sicherung problemlos. Ich habe den Auftrag und auch das Depot neu erstellt. Multi-Volume-Snapshot ist aktiviert. Beim MVS sehe ich zumindest in meinem Fall das eigentliche Problem. Die Einstellung war vorher deaktiviert, trotzdem sind hierzu Fehlermeldungen im Protokoll. Acronis konnte mir bisher nicht sagen, wieso das so ist. Mich würde natürlich interessieren, wie das bei den anderen Autoren aussieht.

PS: Dimitri, so kann man das natürlich auch machen. Jedem das seine. :-)

Beginner
Posts: 0
Comments: 5

#9

@Holger
Irgendwie komme ich leider gar nicht mehr weiter: Multi-Volume-Snapshot ist aktiviert und die Einstellung war vorher auch aktiviert, Depot neu erstellt-> immer wieder die gleiche Fehlermeldung.
Und das neueste Update 11.5.38350 ist auch drauf!
Musste schon wieder für den neuen Kunden das alte Image vom Juni 2013 aufspielen und dann läuft wie schon beschrieben alles...

Beginner
Posts: 0
Comments: 7

#10

Hallo Zusammen!

Danke für das interessante Thema.

Ich habe einige Informationen vorbereitet, die Ihnen interessant und behilflich sein konnten.

1) Unter diesem Link finden Sie VSS Troubleshooting Guide:
http://kb.acronis.com/content/36200

2) Prüfen Sie bitte VSS Logs:
http://kb.acronis.com/content/1830

3) Wenn es um Volume Shadow Copy Error 0x800423f0 geht, machen Sie sich mit diesem Artikel vertraut:
http://kb.backupassist.com/articles.php?aid=2995

4) Überprüfen Sie, ob es hilft auf Voll-VSS-Backup umzuschalten:
http://www.acronis.de/support/documentation/ABR11.5/#12865.html
http://www.gilkirkpatrick.com/Blog/post/2008/08/17/Volume-Shadow-Copy-Se...

5) Überprüfen Sie, ob übliches Windows Backup funktioniert:
http://blogs.msdn.com/b/virtual_pc_guy/archive/2013/02/18/windows-backup...
Falls es auch nicht funktioniert, wenden Sie sich bitte an Microsoft Support

Ich wünsche Ihnen frohe Weihnachten und einen guten Rutsch ins neue Jahr.

Beginner
Posts: 2
Comments: 1

#11

Wir haben bei vielen Servern. Gibt es da bereits eine Lösung?

De Acronis Support kan man leider total vergessen. Da hat man das Gefühl mit einem Praktikanten zu reden.

Wir setzen das aktuelle Build: 14330 ein.

 

Gruß, Herry 

Forum Moderator
Posts: 147
Comments: 5449

#12

Hello Herry,

thank you for your posting! Issues with VSS can have different root causes. The most common troubleshooting steps and known issues are collected in the article https://kb.acronis.com/content/36200 If all steps from the article have been executed and issue still persists, we can only recommend raising a support ticket for the more in-depth investigation. 
If you already have an open support ticket, please share the ticket ID here, so that we can look into the situation.