Skip to main content

Cannot login to "My Account" site

Thread needs solution
Beginner
Posts: 1
Comments: 1

Hello Acronis Forum,

I really hope someone can help me. I cannot login to the "My Account" page to register my products.

Now, before you ask, Yes, I have setup a user and password and I am POSITIVE I am entering the correct password. I have also changed the password.

It appears as though it is going to login, but then just sits at the loading screen infinitely. (The page is blue with three little white moving dots)

I have tried multiple browsers, as well as multiple computers. Ack! What is going on?

Please help,

Tim

I have attached a picture of the infinite loading screen.

 

Attachment Size
loading__screen_acronis.jpg 36.3 KB
0 Users found this helpful
Beginner
Posts: 1
Comments: 1

Just a quick update, I've spoken with an Acronis Technical Support Agent and he directed me to use:

https://www.acronis.com/en-us/my/

 

Instead of:

https://accounts.acronis.com/login

 

Though this hasn't fully solved my issue, he has escalated my ticket to their web development team.