Aller au contenu principal

Upgrade system disk from SATA SSD to M.2 SSD

Thread needs solution
Contributions: 1
Commentaires: 0

I have Disk Director 12, and it failed during the post-reboot operation to clone my 512GB SATA SSD to my 1TB m.2 SSD. Various messages about not being able to copy. If noting specific errors are helpful, I can do that. It only takes about 5 minutes to make an attempt.

I tried both "proportional resize" and "keep as-is" with the same results.

Because this is my system drive, simpler things like "backup and restore" aren't suitable, since they won't properly copy over the MBR info and the hidden partition. Similarly, since my current 512gb system drive is almost full, "just reinstall everything" isn't a reasonable option either.

0 Users found this helpful
Forum Moderator
Contributions: 126
Commentaires: 4929


Hello Chris,

First of all, I'd recommend following

If cloning attempts are still not successful, then I'd really try backup/restore approach using a trial version of Acronis True Image 2019 . If you create a full system backup of your drive, it will contain all hidden partitions and MBR.

First create a system backup (see and then proceed according to [How to] recover an entire disk backup.