Aller au contenu principal

Error 55 very persistent, sometimes disk corruption occurs

Thread needs solution
Beginner
Contributions: 5
Commentaires: 7

[This post has been heavily edited.  I was elsewhere and in a rush with my first post.  I hope this one is far more understandable.]

Before I get to the problem at hand, here is a sample of what my system contains:

Cooler Master Elite 431 Plus Case (with 3.5" hot-swap bay)
ASRock Z77 Extreme6 Motherboard
Two Seagate Momentus XT 500GB SATA 3.0 hard drives in SATA 3.0 sockets
Two Seagate Momentus XT 500GB SATA 2.0 hard drives in SATA 2.0 sockets
One Seagate Barracuda 2TB hard drive in SATA 3.0 socket (plugged into hot-swap bay)
(the other 2 SATA 2.0 sockets are occupied by optical drives)

The problem, I suspect, involves any or all of the following:
Mediasonic HF2-SU2S2 ProBox 4-Bay External Enclosure
http://www.mediasonicstore.com/servlet/the-12/Mediasonic-ProBox-4-Bay/Detail
http://support.mediasonicinc.com/HF2-SU2S2/HF2-SU2S2_Manual.pdf
[USB 2.0 connection to the machine. eSATA is useless because the ProBox enclosure does not have an on-board eSATA port multiplier interface, and my motherboard's external eSATA port is not port-multiplier-ready.  SMART cannot analyze hard drives in this external enclosure.]

I have four 1TB drives in this box:
Two Samsung EcoGreen F2 HD103SI
Two Western Digital Caviar Green WD10EADS

In most activations of my machine, I have little trouble with the hard drive or the external enclosure, so long as I run a check on the drives; but once in a while, I get Error 55, stating that the file system structure is corrupt and unusable. I generally run a Win7 disk check to fix the problem.

Unfortunately, in some cases, Error 55 becomes a prelude to inaccessibility of any one of my hard drives.  The most obvious symptom of a malfunction is when I click on the affected drive in my Win7 Explorer, and either I'm waiting until the next Ice Age for the contents to be displayed, or I get a message saying that the drive is inaccessible.

If I'm lucky, a Win7 disk check will clean up the problem, although in a couple of cases a bunch of files went missing.  I had to use Advanced System Optimizer (http://www.systweak.com/aso/) to find those files and restore them, before moving them to another drive.

If I'm not lucky, a Win7 disk check will also freeze because the drive is inaccessible.  Strange as it may be, running a disk check with Disk Director 11 is much safer.  Not once has it stalled.  Once more, when I opened Disk Director, the drive structure was in place, with the exception that a red circle and explanation point within, appeared, warning me that the partition was corrupted.  Nevertheless, Disk Director's disk check cleaned up the instability.

The problem now is that the instability is becoming a nuisance and also inexplicable, because when I placed each of these 1TB drives inside the hot-swap bay of my desktop to run a SMART analysis, the disk health status of each and every one of my 4 drives was 100%!

Is it possible for a drive at 100% functionality to be in danger of dying?  I've had these drives for more than two and a half years (the oldest of the 4, one of my Samsung drives, purchased Oct. 2010), and the external enclosure for nearly a year and a half.  I have used the enclosure with my laptop, and I have never had a disk instability problem in the enclosure when connected to my laptop.  I doubt that the problem lies within my desktop, because none of my internal drives has ever become unstable, in my current build or my previous build.

It should be noted, though, that I do not have Drive Monitor installed on my laptop, which has led me to suspect that the random (but not all-too-frequent) incidents of external drive corruption arises from the way in which this program examines my drives inside my desktop or in an external enclosure connected by way of USB cable.  Once more, I have noticed a post, in this forum, in which a user has discovered that USB drives might not work if this program is installed.

Could this be the problem?  Or could it be a design flaw regarding my hard drive enclosure?  Could the use of a cheap USB cable (Trisonic, the brand frequently found in 99-cent stores) be the problem? [I have since removed the cable and used the original cable that came with the enclosure.]

Could it be that the transfer of data, to and from my enclosures via USB 2.0 (slow as the data rate is today) be the problem, since the maximum capacity of my enclosure is 4TB? [It took 6 hours for Disk Director's disk check to restore one of my 1TB drives to functionality after my last corruption episode.]

Or is it that my hard drives inside this enclosure are more susceptible to corruption because they all run at 5,400rpm?  Are these drives, and my USB 2.0 enclosure, inadequate for a desktop machine with a Z77 motherboard?  I bought the drives when I still had a machine with an AMD AM2+ motherboard, and bought the enclosure when my machine had a Z68 board.

I am giving serious consideration to selling my 1TB drives and my enclosure (while they are still functional), to replace with high-performance 2TB drives (2 of them) and a USB 3.0 enclosure.

0 Users found this helpful
Beginner
Contributions: 5
Commentaires: 7

UPDATE: It is looking more and more likely that my enclosure is definitely the problem.  Last night, my fourth 1TB drive suddenly became unreadable, peppered by a trainload of Error 55 warnings in my Drive Monitor.  Again, Disk Director 11's disk check fixed the problem.

What convinces me that my Mediasonic HF2-SU2S2 enclosure is the problem is that my 4th drive was empty.  Again, all 4 drives registered 100% health when I tested them inside my desktop with Disk Director and SMART.

I'm already looking for a new enclosure, one that I can trust.  I don't need a RAID 0/1 enclosure.

Forum Hero
Contributions: 613
Commentaires: 8747

Sean,

Have you, run chkdsk /r on all your external drives, and, checked the actual drive and USB cables?

Drive failure and aging/poor quality cables can also cause similar symptons.

Beginner
Contributions: 0
Commentaires: 1

thanks for the info