Aller au contenu principal

Not able to backup with unknown reason

Thread needs solution
Contributions: 1
Commentaires: 0

Everyone, I have recently installed the Acronis True Image for Western Digital and tried to backup the data inside My Passport of WD. Yet, it shew that the file system there is incorrect and asked me to use the check the WD Drive Utilities to check what had happened.  After the quick check, it shew that my hardware (My Passport) did not pass the test.  So what should I do next? I am quite frustrated in dealing with my hardware right now!

Besides, I cannot access my hardware and I have tried to look at the properties there, it shew that there was no memory originally and I had used 0 KB.  Yet, through using the Acronis True Image for Western Digital, I found that my files inside occupied roughly 1.8TB memory.  Could I still get all my files using the recovery function or using the backup function?  Thank you!

0 Users found this helpful
Contributions: 110
Commentaires: 29183

Aalis, welcome to these public User Forums.

From the information above, it seems likely that you have a failing WD My Passport drive, and if this is failing the WD Drive Utilities tests, then the data on that drive may be lost.

Acronis True Image (ATI) is not a disk drive recovery program and cannot be used for this purpose.

You could try to make a 'sector-by-sector' backup of the My Passport drive but that may also fail if the drive is unreadable or has permanent hardware errors.

If the My Passport drive is shown in Windows Explorer you could try to copy any files or folders using normal Copy & Paste commands but if Windows cannot open it, then you would need to find a disk recovery specialist to help you.