Salta al contenuto principale

Acronis Ransomware Protection window won’t open

Thread needs solution
Messaggi: 1
Commenti: 0

I first downloaded ARP a few weeks or months ago, and it was working fine. The program still executes at Windows startup and I still see two ARP programs in my task manager. However, when I click the icon, nothing opens. Unless I’m somehow wildly misremembering, there’s supposed to be a window/interface that opens, but it isn’t doing that now. I haven’t actually bothered to open it for a few weeks until yesterday, so I don’t know when the issue started. I’ve tried almost everything. I’ve tried restarting the PC, running as an administrator, and reinstalling. I even tried turning off my antivirus (Kaspersky). Just about the only thing I haven’t tried is completely refreshing/resetting/reinstalling Windows itself, and while that’s not entirely out of the question (PC has been acting up lately anyway), I’d rather not have to. Is there any possible solution to this?

0 Users found this helpful
Forum Moderator
Messaggi: 137
Commenti: 5376


Hello Brandyn,

if running the installation file as Administrator and adding Acronis to exclusions in the antivirus software don't help to solve the issue, we can only recommend testing a free trial of Acronis True Image 2020. Since Acronis Ransomware Protections is a freeware product, the more in-depth investigation with the help of Acronis support engineers is unfortunately not possible for this product.