Salta al contenuto principale

Failed to resolve the selected disk

Thread needs solution
Beginner
Messaggi: 3
Commenti: 0

Acronis just helped me update our installation to 5.0.1,660 so it will communicate with the new Dell Intel NICs after PXE boot, but now trying to image an old Dell Latitude 7440 using PXE, when I start the existing deployment task, we've used all along, it fails with the below error. It can't be a permissions issue since the laptop was PXE booted, and I verified it still works fine on a different model client.

I also tried loading a basic installation of Windows 7 before reimaging rather than a blank SSD.

Host '172.16.30.234' has failed the deployment.
Additional info:
--------------------
Error code: 1
Module: 52
LineInfo: 6934824D6BD2F69E
Fields: $module : "osd_server_vs_1660"
Message: Host '172.16.30.234' has failed the deployment.
--------------------
Error code: 6
Module: 51
LineInfo: A6EF0BE19DB526B2
Fields: $module : "osd_server_vs_1660"
Message: Failed to resolve the selected disk.
--------------------
Error code: 51
Module: 51
LineInfo: 3E2D5B2FC56679AF
Fields: $module : "osd_server_vs_1660"
Message: Failed to resolve disk by number '1'.

0 Users found this helpful
Forum Hero
Messaggi: 68
Commenti: 8216

#1

I don't believe 1660 has the correct drivers either - I believe you need the 1662 which introduced the proper NIC drivers.  1666 then introduced NVME PCIE hard drive support.

Interesting, you and Doug are both having the exact same error, but you are on 1660 and he is using 1666 (and you have different hardware)

http://forum.acronis.com/forum/123927

Did you upgrade over the top of your previous build?  Perhaps you need to restart the PXE service as a by product.  I can't find the thread, but one of the engineers suggested removing the PXE component, rebooting, then reinstalling the PXE component for another person which they responded helped with PXE.

Also, the 7440/7470 don't seem to like legacy mode at all in our environment - even when legacy is specifically enabled in the bios.  If we try to PXE boot using legacy NIC, it fails. If we PXE boot with UEFI PXE it works fine.  

As for your image deployment, what was the SATA mode set to in the bios when the image was created (SATA, AHCI or RAID).  Make sure to set the same in the bios on the 7440 - I belive the ultrabooks are all coming with this set to RAID-ON by default - even those with a single drive.  If you have an NVME PCIE drive, this may be the real issue though which would require using build 1666.  I'll send it to you in PM. 

Beginner
Messaggi: 0
Commenti: 1

#2

I am also seeing the same problems with a new Dell Optiplex 7040.  Errors shown below.  Our Optiplex systems are using NVME PCIE drives which forces me to believe we also need build 1666 or better.  How do I get access to the latest build?  I have build 1660 which I just downloaded last week.  Is build 1666 not yet released to the public?

 

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

 

 

Host '192.100.100.125' has failed the deployment.
Additional info:
--------------------
Error code: 1
Module: 52
LineInfo: 6934824D6BD2F69E
Fields: $module : "osd_server_vs_1660"
Message: Host '192.100.100.125' has failed the deployment.
--------------------
Error code: 6
Module: 51
LineInfo: A6EF0BE19DB526B2
Fields: $module : "osd_server_vs_1660"
Message: Failed to resolve the selected disk.
--------------------
Error code: 51
Module: 51
LineInfo: 3E2D5B2FC56679AF
Fields: $module : "osd_server_vs_1660"
Message: Failed to resolve disk by number '1'.

Forum Hero
Messaggi: 68
Commenti: 8216

#3

Yup, you need 1666 for these systems.  Sending you a PM with the download link.  Not sure what the hold up is with getting a public release - 1662/1666 beta have been a few months now and really do nothign more than provide the updated driver support.  I use 1666 with all of the latest Dell ultrabooks and Precisions.

As a test, boot the Dell with your current Linux recovery media and attempt to run image creator - does it show your internal hard drive?  Probably not.

1) Dell is shipping these in RAID mode.  That means you need the IRST drivers and Linux doesn't have them

2) The 1660 media doesnt' have the NVME drivers either.

Easiest work-a-round... use the 1666 beta, but if you want to leave teh system with the SATA mode as RAID, just switch the bios to AHCI (for the purpose of the backup which will alleviate the need to use WinPE which you'd then need to inject the IRST drivers in as well).  Once the backup is complete, then switch the sata mode back to RAID.  

We've just been setting the SATA mode to AHCI and leaving it that way.  I have found no speed performance difference with either since these are not using SATA and are directly attached to the PCIE Bus.  In order for Windows to remain bootable if you want to permanently switch to AHCI, you need to run the driver preparation in Windows first.  Here's the Microsoft KB article and fix it tool that will do this for you (or you can edit the registry manually with the instructions in the article)

Error message occurs after you change the SATA mode of the boot drive

 

Of course, before you do this... try switching the SATA mode in teh bios first and see if it just boots or not - Windows 10 is pretty good with this compared to older OSes.  And if it doesn't work.  Then use the work-a-round above and take an image first (just to be on the safe side - it works, but better to be safe than sorry if you haven't tried this before). 

Beginner
Messaggi: 0
Commenti: 1

#4

I have the same exact problem with my Dell 7040.  Is there anyway I can get a copy of 1666?  I am using 1660.

Forum Hero
Messaggi: 68
Commenti: 8216

#5

Nucor I've sent you a PM with the link.

Beginner
Messaggi: 0
Commenti: 1

#6

I have the same exact problem with my HP EliteDesk 800G1. Is there anyway I can get a copy of 1666? I am using 1660.

Forum Moderator
Messaggi: 124
Commenti: 4763

#7

Vyacheslav, the latest available build for Acronis Snap Deploy 5 can be found here 

Build 1690

Beginner
Messaggi: 0
Commenti: 1

#8

Hello we're having the same issue with the Dell 7050 is there any way I can get a link for the new build as well?

Beginner
Messaggi: 0
Commenti: 1

#9

Im having this problem as well, but the link died :(

Forum Moderator
Messaggi: 124
Commenti: 4763

#10
Martin Jensen wrote:

Im having this problem as well, but the link died :(

Hello Martin,

all the fixes and enhancements from the old non-official builds have been already incorporated into the released build, currently 1971 https://forum.acronis.com/forum/acronis-snap-deploy-5/acronis-snap-deploy-5-update-5-released